Вопрос задан 22.04.2018 в 21:42. Предмет Информатика. Спрашивает Рогов Паша.

Нужно написать программу, которая сформировывает случайным образом 10 чисел в интервале от -100 до

100 и находит среднее арифметическое положительных чисел, являющихся нечетными. Программа должна быть выполнена в том же стиле, что и программа на фото, так по заданию. Пожалуйста, помогите. Сколько пытаюсь... не выходит...
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Галайко Олег.

Const n=10; 
var a,s,k,i:integer; 
begin
Randomize;
s:=0; k:=0;
writeln('Числа:');
for i:=1 to n do
 begin
 a:=random(201)-100;
 write(a:5);
 if (a>0)and(a mod 2 = 1) then begin s:=s+a; k:=k+1; end;
 end;
writeln;
if k>0
 then writeln('Среднее арифметическое положительных нечетных чисел = ',s/k:5:2)
 else writeln('Среди чисел нет положительных нечетных');
end.

Пример:
Числа:
   11  -60   13  -62   15  -92  -71   87  -15   12
Среднее арифметическое положительных нечетных чисел = 31.50

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос