 
Вопрос задан 27.12.2018 в 09:55.
Предмет Информатика.
Спрашивает Abukina Lena.
Написать программу для подсчета суммы введенных с клавиатуры чисел до тех пор, пока не будет введен
0. 0
        0
         0
        0
    Ответы на вопрос
 
        Отвечает Миронов Александр.
                
     //PascalABC.NET
//Версия 3.3, сборка 1634
begin
write(ReadSeqIntegerWhile(x->x<>0).Sum);
end.
                                        //Версия 3.3, сборка 1634
begin
write(ReadSeqIntegerWhile(x->x<>0).Sum);
end.
 0
                    0
                     0
                    0
                 
        Отвечает Сподырякина Маша.
                
     Var a,s:integer;
begin
s:=0;
readln(a);
while a<>0 do
begin
s:=s+a;
readln(a);
end;
writeln('s = ',s);
end.
Пример:
5
8
3
4
6
0
s = 26
                                        begin
s:=0;
readln(a);
while a<>0 do
begin
s:=s+a;
readln(a);
end;
writeln('s = ',s);
end.
Пример:
5
8
3
4
6
0
s = 26
 0
                    0
                     0
                    0
                Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
	- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			