Вопрос задан 02.04.2018 в 08:13. Предмет Информатика. Спрашивает Катышев Павел.

PASCAL ABCНапишите программу, которая определяет правильность записи целого числа в восьмеричной

системе счисления. Формат входных данных На вход программы поступает символьная строка. Формат выходных данных Программа должна вывести ответ 'YES', если строка представляет собой правильную запись целого числа в восьмеричной системе счисления, и 'NO', если запись ошибочна.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Хафизова Ангелина.

Var value, error: integer;
begin
var s:=readstring ('Введите строку: ');
val (s, value, error);
if (error<>0) or ('9' in s) or ('8' in s) then write ('NO') else write ('YES');
end.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос