Напишите программу ( на алгоритмическом языке Паскаль), которая выводит таблицу кубов первых пяти
целых положительных четных чисел.Ответы на вопрос
uses crt;
var i:integer;
begin
for i:=1 to 10 do
begin
if (i mod 2 = 0)then
writeln(i,' v kube = ',i*i*i);
end;
readln;
end.
Program ipon;
const n=5;
var i: integer;
begin
writeln('*** alphaues is thinking... ***');
for i:=1 to n do
writeln(i*2,' в кубе равно ',(i*2)*(i*2)*(i*2));
end.
Вот пример программы на языке Паскаль, которая выводит таблицу кубов первых пяти целых положительных четных чисел:
```pascal program CubeTable;
var i, number: integer;
begin writeln('Number Cube'); writeln('----------------'); number := 2; // начальное значение for i := 1 to 5 do begin writeln(number:4, ' ', number * number * number:5); number := number + 2; // увеличиваем число на 2 на каждой итерации end; readln; end. ```
Пояснение к программе: - Мы объявляем переменные `i` и `number` типа `integer`. - В цикле `for` от 1 до 5 мы выводим значения `number` и его куб на каждой итерации. - Переменная `number` инициализируется значением 2, так как первое четное положительное число - 2. - На каждой итерации мы увеличиваем значение `number` на 2, чтобы получить следующее четное число. - Выводим таблицу с заголовком "Number Cube" и разделительной линией "----------------". - В конце программы вызываем `readln`, чтобы программа не закрылась сразу после вывода таблицы.
Результат выполнения программы будет выглядеть следующим образом:
``` Number Cube ---------------- 2 8 4 64 6 216 8 512 10 1000 ```
Таким образом, программа выводит таблицу кубов первых пяти целых положительных четных чисел: 2, 4, 6, 8 и 10.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
