Вопрос задан 24.08.2018 в 03:01. Предмет Информатика. Спрашивает Писакин Валентин.

Составить программу на языке паскаль АБС.Дано радиусы двух окружностей. Найти площадь кольца.

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Волков Артём.
Простите-си++ и си только знаю.
0 0
Отвечает Просёлова Анастасия.

sasha12341234 издеваешься? знать с++ и не написать на паскале??
ну если дано R и r
var r,r1:integer; s,pi:real;
begin
pi:=3.14;
r:=15; //big
r1:=10; //small
s:=pi*(r-r1);
writeln(s);
readln
end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Программа на языке Паскаль для нахождения площади кольца по заданным радиусам двух окружностей будет выглядеть следующим образом:

```pascal program calculate_ring_area; var radius1, radius2, ring_area: real;

begin // Ввод радиусов двух окружностей write('Введите радиус первой окружности: '); readln(radius1); write('Введите радиус второй окружности: '); readln(radius2); // Проверка на корректность введенных данных if (radius1 <= 0) or (radius2 <= 0) then begin writeln('Радиусы окружностей должны быть положительными числами.'); exit; end; // Вычисление площади кольца ring_area := pi * (sqr(radius2) - sqr(radius1)); // Вывод результата writeln('Площадь кольца с радиусами ', radius1:0:2, ' и ', radius2:0:2, ' равна ', ring_area:0:2); end. ```

Программа сначала запрашивает у пользователя радиусы двух окружностей, затем проверяет корректность введенных данных (радиусы должны быть положительными числами). Если данные некорректны, программа выводит сообщение об ошибке и завершает свою работу. В противном случае, программа вычисляет площадь кольца по формуле `S = π * (r2^2 - r1^2)`, где `r1` и `r2` - радиусы окружностей. Затем программа выводит результат вычисления на экран.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос