Составьте программу, вычисляющую, является ли данное слово "перевертышем"(так называются
слова,читающиеся одинаково слева направо и справа налево,например:топот,шалаш) паскальОтветы на вопрос
var s,d:string;
begin;
read(s); s:=lowercase(s);
if reversestring(s)=s then write('Перевёртыш') else write('Не перевёртыш');
end.
Для проверки, является ли данное слово "перевертышем", можно написать программу на языке Паскаль. Вот пример такой программы:
```pascal program CheckPalindrome;
var word, reversedWord: string; i: integer; isPalindrome: boolean;
begin // Ввод слова writeln('Введите слово:'); readln(word);
// Переворачиваем слово reversedWord := ''; for i := length(word) downto 1 do reversedWord := reversedWord + word[i];
// Проверяем, является ли слово перевертышем isPalindrome := word = reversedWord;
// Выводим результат if isPalindrome then writeln('Данное слово является перевертышем.') else writeln('Данное слово не является перевертышем.');
readln; end. ```
В этой программе мы сначала запрашиваем у пользователя слово, затем переворачиваем его и сравниваем с исходным словом. Если они совпадают, то слово является перевертышем, иначе - нет.
Примечание: Пожалуйста, учтите, что данная программа написана на языке Паскаль и требует его компилятора для выполнения. Если у вас нет компилятора Паскаля, вы можете использовать онлайн-среду разработки, такую как "Online Pascal Compiler" или "JDoodle", чтобы выполнить эту программу.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
