Вопрос задан 03.08.2018 в 20:54. Предмет Информатика. Спрашивает Кирилл Васильев.

Составьте программу (блок схема и на Паскаль) Нахождения площади треугольникапо формуле Герона если

извесны все три стороны
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Вилаев Григорий.
Var
a,b,c,p,S:real;
Begin
Write('a = ');
ReadLn(a);
Write('b = ');
ReadLn(b);
Write('c = ');
ReadLn(c);
p:=(a+b+c)/2;
S:=sqrt(p*(p-a)*(p-b)*(p-c));
WriteLn('S = ',S);
End.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Я могу помочь вам составить программу на Паскаль для нахождения площади треугольника по формуле Герона, если известны все три стороны. Вот блок-схема алгоритма:

![Блок-схема алгоритма]

Вот код программы на Паскаль:

```pascal program geron; var a, b, c, p, s: real; begin writeln('Введите длины сторон треугольника:'); readln(a, b, c); p := (a + b + c) / 2; // полупериметр s := sqrt(p * (p - a) * (p - b) * (p - c)); // площадь по формуле Герона writeln('Площадь треугольника равна ', s:0:2); end. ```

Надеюсь, это было полезно. Если у вас есть еще вопросы, я рад помочь.блок схема на Паскаль

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос