
Pascal !! Помогите пожалуйста)Надо составить программу в Паскале, где в двумерном массиве
вычисляется количество нулей на главной диагонали.Завтра сдавать надо( В интернете не нашла ничего толкового..

Ответы на вопрос




i,j,s:integer;
a:array[1..10,1..10]of integer;
begin
writeln('Исходный массив:');
for i:=1 to 10 do
begin
for j:=1 to 10 do
begin
a[i,j]:=random(-10,10);
if (a[i,j]=0) and (i=j) then s:=s+1;
write(a[i,j]:3)
end;
writeln
end;
writeln('Число нулей на главной диагонали: ',s)
end.



Конечно, я могу помочь с этим заданием. Вот пример программы на Pascal, которая вычисляет количество нулей на главной диагонали двумерного массива:
```pascal program CountZerosOnDiagonal;
const N = 3; // размерность массива
var arr: array[1..N, 1..N] of Integer; i, j, count: Integer;
begin // заполнение массива (можно ввести значения с клавиатуры или сгенерировать случайные числа) for i := 1 to N do for j := 1 to N do arr[i, j] := Random(3); // генерация случайных чисел от 0 до 2
// вывод массива (для наглядности) for i := 1 to N do begin for j := 1 to N do Write(arr[i, j], ' '); Writeln; end;
// вычисление количества нулей на главной диагонали count := 0; for i := 1 to N do if arr[i, i] = 0 then Inc(count);
// вывод результата Writeln('Количество нулей на главной диагонали: ', count);
end. ```
Это простая программа, которая создает двумерный массив, заполняет его случайными числами от 0 до 2, выводит массив на экран, затем вычисляет количество нулей на главной диагонали и выводит результат. Надеюсь, это поможет вам выполнить задание. Удачи!


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili