
НАПИСАТЬ ПРОГРАММУ НА С++Написали два числа. Если первое число увеличить на 30%, а второе уменьшить
на 10%, то их сумма увеличиться на 6. Если же первое число уменьшить на 10%, а второе на 20%, то их сумма уменьшится на 16. Какие числа были написаны.

Ответы на вопрос

Ответ:
#include <iostream>
using namespace std;
int main() {
int x,y;
for(int i=1;i<10000;i++){
for(int b=1;b<10000;b++){
if(i*1.3+b*0.9-6==i+b){
if(i*0.9+b*0.8+16==i+b){
x=i;
y=b;
break;
}
else{continue;}
}
}
}
cout<<x<<" "<<y;
}
Объяснение:



Для решения данной задачи вам потребуется написать программу на языке C++. В программе вы будете работать с двумя числами и выполнять над ними определенные операции.
Алгоритм решения:
1. Объявите две переменные для хранения чисел: `num1` и `num2`. 2. Используйте операторы увеличения и уменьшения для изменения значений переменных `num1` и `num2` в соответствии с условиями задачи. 3. Вычислите сумму чисел `num1` и `num2` и сохраните ее в переменную `sum`. 4. Проверьте, выполняются ли условия задачи, что сумма чисел после изменения должна увеличиться на 6 или уменьшиться на 16. 5. Если условия выполняются, выведите значения чисел `num1` и `num2`. Если условия не выполняются, выведите сообщение о том, что нет решения для данной задачи.Пример кода на C++:
```cpp #includeint main() { double num1, num2; // Введите значения чисел cout << "Введите первое число: "; cin >> num1; cout << "Введите второе число: "; cin >> num2; // Измените значения чисел в соответствии с условиями задачи num1 *= 1.3; // увеличить на 30% num2 *= 0.9; // уменьшить на 10% // Вычислите сумму чисел double sum = num1 + num2; // Проверьте условия задачи if (sum * 100 == (num1 + num2 + 6) * 100) { cout << "Первое число: " << num1 << endl; cout << "Второе число: " << num2 << endl; } else if (sum * 100 == (num1 + num2 - 16) * 100) { cout << "Первое число: " << num1 << endl; cout << "Второе число: " << num2 << endl; } else { cout << "Нет решения для данной задачи." << endl; } return 0; } ```
Примечание: В данном примере предполагается, что пользователь вводит числа с плавающей точкой. Если вам нужны целочисленные значения, замените `double` на `int` и используйте операторы деления и умножения нацело.
Например, если первое число увеличивается на 30%, а второе уменьшается на 10%, их сумма увеличивается на 6, то исходные числа могут быть, например, 10 и 20. Если первое число уменьшается на 10%, а второе на 20%, их сумма уменьшается на 16, то исходные числа могут быть, например, 30 и 40. Однако, это только примеры, и другие числа также могут удовлетворять условиям задачи.


Похожие вопросы
Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili