Вопрос задан 06.05.2019 в 06:39. Предмет Информатика. Спрашивает Кострик Алинка.

Программа в C++ Напишите программу, которая вводит натуральное число N и выводит первые N чётных

натуральных чисел. Входные данные Входная строка содержит единственное число – требуемое количество чисел N . Выходные данные Программа должна вывести в одну строчку N первых чётных натуральных чисел, разделив их пробелами. Примеры входные данные 5 выходные данные 2 4 6 8 10
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Ким Паша.
  1 #include <cstdio>
  2
  3 int
  4 main(void)
  5 {
  6     int n = 0;
  7     scanf("%d", &n);
  8     for (int i = 0, even_num = 2; i < n; i++, even_num += 2) {
  9         printf("%d ", even_num);
 10     }
 11     return 0;
 12 }
0 0
Отвечает Чернышёв Виктор.
#include <iostream>
using namespace std;
 
int main()
{
    int n = 0;
    cin >> n;
    for (int i = 0; i < n * 2; i += 2) {
        cout << i << endl;
    }
    return 0;
}
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Приведенная ниже программа на языке C++ выполняет заданную задачу:

```cpp #include

int main() { int N; std::cout << "Введите количество чисел N: "; std::cin >> N;

int count = 0; int number = 2;

std::cout << "Первые " << N << " четных натуральных чисел: "; while (count < N) { if (number % 2 == 0) { std::cout << number << " "; count++; } number++; }

return 0; } ```

Программа начинает с запроса у пользователя количества чисел `N`. Затем она инициализирует переменные `count` и `number`. Переменная `count` используется для отслеживания количества уже найденных четных чисел, а переменная `number` представляет текущее число, которое проверяется на четность и выводится, если оно четное.

Затем программа выводит сообщение и начинает цикл `while`, который выполняется, пока не будет найдено `N` четных чисел. В каждой итерации цикла проверяется, является ли текущее число четным (путем проверки остатка от деления на 2). Если число четное, оно выводится на экран, увеличивается счетчик `count`, и переменная `number` увеличивается на 1. Если число нечетное, программа просто увеличивает `number` на 1 и продолжает итерацию цикла.

После завершения цикла программа завершается, возвращая 0.

Пример работы программы:

``` Введите количество чисел N: 5 Первые 5 четных натуральных чисел: 2 4 6 8 10 ```

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос