Вопрос задан 01.12.2023 в 20:05. Предмет Информатика. Спрашивает Смирнова Оля.

1. Написать программу. Дано трехзначное число, определить является ли сумма его цифр кратна числу х

(х - любое число, которое введет пользователь). Пример: введите трехзначное число: 345 Введите любое целое число: 6 Сумма цифр числа 345 кратна числу 6 (python) СРОЧНО ПОМОГИТЕ ПОЖАЛУЙСТА!
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Шамиль Исмаилов.

Ответ:

ЕСЛИ ПРОГРАММА НЕ РАБОТАЕТ - СМОТРИ ФОТО

a = 345 # это число можно менять, если надо, чтобы пользователь его вводил, напишите вместо числа int(input())

x = int(input())

a = str(a)

sum = 0

for j in a:

   sum += int(j)

if sum % x == 0:

   print('КРАТНО')

else:

   print('НЕ КРАТНО')


0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Программа, решающая данную задачу на языке Python, может выглядеть следующим образом:

```python number = input("Введите трехзначное число: ") x = int(input("Введите любое целое число: "))

# Проверяем, является ли число трехзначным if len(number) != 3: print("Введено некорректное число!") else: # Считаем сумму цифр числа digit_sum = int(number[0]) + int(number[1]) + int(number[2]) # Проверяем, является ли сумма цифр кратной числу x if digit_sum % x == 0: print("Сумма цифр числа", number, "кратна числу", x) else: print("Сумма цифр числа", number, "не кратна числу", x) ```

В данной программе мы сначала считываем трехзначное число и число x, введенные пользователем. Затем мы проверяем, является ли введенное число трехзначным. Если да, то мы считаем сумму его цифр и проверяем, является ли эта сумма кратной числу x. В зависимости от результата, выводим соответствующее сообщение.

Например, если пользователь введет трехзначное число 345 и число x равное 6, то программа выведет "Сумма цифр числа 345 кратна числу 6".

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос