
Составьте программу в Паскале . Вводиться два числа .Определить ,имеют ли они одинаковую чётность
(оба чётные либо оба не чётные) Например:введите числа А и В -10 20 Числа имеют одинаковую чётность

Ответы на вопрос

Ответ:
var i,z:Integer;
begin
writeln('Введите числа: ');
readln(i);
readln(z);
if (((i mod 2 = 0) and (z mod 2 = 0)) or ((i mod 2 <> 0) and (z mod 2 <> 0))) then
writeln('Числа имеют одинаковую чётность')
else
writeln('Числа имеют неодинаковую чётность');
end.



Вот пример программы на языке Паскаль, которая позволяет определить, имеют ли два введенных числа одинаковую четность:
```pascal program CheckParity; var A, B: integer; begin writeln('Введите два числа:'); readln(A, B); if (A mod 2 = 0) and (B mod 2 = 0) then writeln('Числа имеют одинаковую четность') else if (A mod 2 <> 0) and (B mod 2 <> 0) then writeln('Числа имеют одинаковую четность') else writeln('Числа имеют разную четность'); end. ```
Программа запрашивает у пользователя два числа и затем проверяет их четность с помощью оператора `mod`. Если оба числа являются четными или оба числа являются нечетными, программа выводит сообщение "Числа имеют одинаковую четность". В противном случае, программа выводит сообщение "Числа имеют разную четность".
Например, если ввести числа -10 и 20, программа выведет сообщение "Числа имеют одинаковую четность".
Примечание: Программа написана на языке Паскаль, который является устаревшим и редко используется в современном программировании. Если вам нужна программа на более современном языке, например, на C++ или Python, дайте мне знать, и я могу предоставить вам код на другом языке программирования.


Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili