Вопрос задан 14.11.2023 в 03:56. Предмет Информатика. Спрашивает Nani Alisa.

Массив из 60 элементов (количество выпускников школы) хранит результаты экзамена, полученные

выпускниками на централизованном тестировании(баллы от 0 до 100). Составьте программу, которая вычисляет, сколько процентов выпускников успешно сдали экзамен( получили более 25 баллов). Решить в Pascal ABC (не АВС.Net)​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Nabi Arujan.

Программа:

Pascal:

var

 arr: array[1..60] of integer;

 i, n: integer;

begin

 for i := 1 to 60 do begin

   arr[i] := random(0,100);

   if arr[i] > 25 then inc(n);

 end;

 writeln('Оценки: ', arr);

 writeln('Успешно сдали экзамен ', n, '% учеников.');

end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Я попробую помочь вам с вашим заданием. Вот программа на языке Pascal ABC, которая вычисляет процент выпускников, успешно сдавших экзамен:

```pascal program exam; var a: array [1..60] of integer; // массив для хранения баллов i, n: integer; // счетчик и переменная для количества успешных выпускников p: real; // переменная для процента begin n := 0; // инициализируем переменную нулем for i := 1 to 60 do // цикл по элементам массива begin readln(a[i]); // вводим баллы if a[i] > 25 then // если баллы больше 25 n := n + 1; // увеличиваем количество успешных выпускников на 1 end; p := n / 60 * 100; // вычисляем процент writeln('Процент выпускников, успешно сдавших экзамен: ', p:0:2); // выводим результат с двумя знаками после запятой end. ```

Надеюсь, это было полезно. Удачи вам в учебе!

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос