Написать программу, которая создает и заполняет массив из 10 элементов случайными целыми числами в
диапазоне от 10 до 99. Упорядочить массив по возрастанию последней цифры числа. вывести массив Очень срочно! Язык Паскаль.Ответы на вопрос
Ответ:
var
arr: array[1..10] of integer;
i, k, j: integer;
begin
randomize;
writeln('Массив: ');
for i := 1 to 10 do arr[i] := random(10,99);
for i := 1 to 10 do
for k := 1 to 9 do
if (arr[k] mod 10) > (arr[k + 1] mod 10) then begin
j := arr[k];
arr[k] := arr[k + 1];
arr[k + 1] := j;
end;
for i := 1 to 10 do write(arr[i],' ');
end.
var a : array [1..10] of integer;
i, j, temp : integer;
begin
randomize;
write('Сгенерированный массив: ');
for i := 1 to 10 do
begin
a[i] := random(90) + 10;
write(a[i], ' ');
end;
for i := 1 to 10 do
for j := 1 to 9 do
begin
if (a[j] mod 10) > (a[j+1] mod 10) then
begin
temp := a[j];
a[j] := a[j+1];
a[j+1] := temp;
end;
end;
writeln;
write('Отсортированный массив: ');
for i := 1 to 10 do
write(a[i], ' ');
end.
Конечно, вот программа на языке Pascal, которая создает массив из 10 элементов случайными целыми числами в диапазоне от 10 до 99, затем упорядочивает этот массив по возрастанию последней цифры числа и выводит его:
```pascal program SortArrayByLastDigit;
const ARRAY_SIZE = 10; type IntArray = array[1..ARRAY_SIZE] of Integer;
var numbers: IntArray; i, j, temp: Integer;
// Функция для генерации случайных чисел от 10 до 99 function GenerateRandomNumber: Integer; begin Randomize; GenerateRandomNumber := Random(90) + 10; end;
// Процедура для заполнения массива случайными числами procedure FillArrayRandom(var arr: IntArray); var i: Integer; begin for i := 1 to ARRAY_SIZE do arr[i] := GenerateRandomNumber; end;
// Процедура для вывода массива procedure PrintArray(arr: IntArray); var i: Integer; begin writeln('Отсортированный массив:'); for i := 1 to ARRAY_SIZE do write(arr[i], ' '); end;
// Процедура для сортировки массива по возрастанию последней цифры числа procedure SortArrayByLastDigit(var arr: IntArray); begin for i := 1 to ARRAY_SIZE - 1 do begin for j := i + 1 to ARRAY_SIZE do begin if arr[i] mod 10 > arr[j] mod 10 then begin temp := arr[i]; arr[i] := arr[j]; arr[j] := temp; end; end; end; end;
begin // Заполняем массив случайными числами FillArrayRandom(numbers); // Выводим исходный массив writeln('Исходный массив:'); for i := 1 to ARRAY_SIZE do write(numbers[i], ' ');
// Сортируем массив по последней цифре числа SortArrayByLastDigit(numbers); // Выводим отсортированный массив PrintArray(numbers); end. ```
Эта программа создает массив из 10 элементов, заполняет его случайными числами в диапазоне от 10 до 99, затем сортирует этот массив по возрастанию последней цифры числа и выводит исходный и отсортированный массивы.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
