Составьте программу на паскале, где надо найти сумму всех чётных чисел от 20 до 40
Ответы на вопрос
Ответ:
var i,s:integer;
begin
s:=0;
for i:=20 to 40 do
if i mod 2=0 then s:=s+i;
write(s)
end.
На языке PascalAВC.NET в одну строчку:
## Range(20,40,2).Sum.Print // результат 330
Вот пример программы на Pascal, которая находит сумму всех четных чисел от 20 до 40:
```pascal program SumOfEvenNumbers;
var i, sum: integer;
begin sum := 0;
for i := 20 to 40 do begin if i mod 2 = 0 then sum := sum + i; end;
writeln('Сумма всех четных чисел от 20 до 40: ', sum); end. ```
В этой программе используется цикл `for`, который перебирает все числа от 20 до 40. Внутри цикла проверяется, является ли текущее число четным с помощью оператора `mod`. Если число четное, то оно добавляется к переменной `sum`. В конце программы выводится результат - сумма всех четных чисел от 20 до 40.
Примечание: Программа написана на языке Pascal. Если вы хотите запустить эту программу, вам понадобится компилятор Pascal, такой как Free Pascal или Turbo Pascal.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
