
Написать программу на языке Паскаль. 1.Дан целочисленный массив из 31 элемента, в котором записаны
значения температуры воздуха в марте. Элементы массива могут принимать значения от (–20) до 20. Подсчитайте среднюю температуру по всем дням, когда была оттепель (температура поднималась выше нуля) 2. В массиве X(m) заменить элементы с четными номерами суммой элементов с нечетными номерами. Заранее спасибо)

Ответы на вопрос

//PascalABC.NET (версия 3.1, сборка 1210 от 29.03.2016)
const m = 31;
var a:array[1..m] of integer;
i,s,n:integer;
begin
for i:=1 to m do begin
a[i]:=random(-20,20);
if a[i]>0 then begin
s:=s+a[i];n:=n+1;
end;
end;
println('Температуры за месяц :'); a.println;
writeln('Средняя в оттепель :',s/n:0:3);
end.
Тестовое решение:
Температуры за месяц :
16 7 19 -7 -18 6 12 -18 -5 -10 8 -4 10 4 10 5 -3 14 -7 -8 2 7 4 -7 18 4 -12 -5 -9 7 -5
Средняя в оттепель :9.000
//Задание №2
//PascalABC.NET (версия 3.1, сборка 1210 от 29.03.2016)
const m = 10;
var a:array[1..m] of integer;
i,s,n:integer;
begin
for i:=1 to m do begin
a[i]:=random(-20,20);
if i mod 2<>0 then s:=s+a[i];
end;
writeln('Исходный массив :'); a.println;
for i:=1 to m do
if i mod 2=0 then a[i]:=s;
writeln('Сумма на нечетных местах = ',s);
writeln('Изиененный массив :'); a.println;
end.
Тестовое решение:
Исходный массив :
-6 15 5 -11 18 4 17 -9 -15 -16
Сумма на нечетных местах = 19
Изиененный массив :
-6 19 5 19 18 19 17 19 -15 19



Программа на языке Паскаль, которая решает данную задачу:
```pascal program AverageTemperature;
const N = 31; // размер массива
var temperatures: array[1..N] of integer; // целочисленный массив i, sum, count: integer; averageTemperature: real;
begin // Ввод значений температуры воздуха в марте writeln('Введите значения температуры воздуха в марте:'); for i := 1 to N do begin write('День ', i, ': '); readln(temperatures[i]); end;
// Подсчет средней температуры в дни оттепели sum := 0; count := 0; for i := 1 to N do begin if temperatures[i] > 0 then begin sum := sum + temperatures[i]; count := count + 1; end; end;
if count > 0 then begin averageTemperature := sum / count; writeln('Средняя температура в дни оттепели: ', averageTemperature:0:2); end else writeln('В марте не было дней оттепели.');
// Замена элементов с четными номерами суммой элементов с нечетными номерами for i := 2 to N step 2 do begin temperatures[i] := temperatures[i - 1] + temperatures[i + 1]; end;
// Вывод измененного массива writeln('Измененный массив:'); for i := 1 to N do begin write(temperatures[i], ' '); end; writeln; end. ```
Программа сначала запрашивает у пользователя значения температуры воздуха в марте и записывает их в массив `temperatures`. Затем происходит подсчет средней температуры в дни оттепели, где температура поднималась выше нуля. Если таких дней нет, выводится соответствующее сообщение. Далее происходит замена элементов с четными номерами суммой элементов с нечетными номерами. И, наконец, выводится измененный массив.


Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili