Вопрос задан 06.11.2023 в 00:22. Предмет Информатика. Спрашивает Акулов Илья.

Напишите программу, которая выводит на экран первую и последнюю цифру четырехзначного числа 3004.

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Чебан Никита.

Ответ:

#include <iostream>

using namespace std;

int main()

{

   char*arr = new char[4];

   cin >> arr;

   cout << arr[0] << " " << arr[3];

   return 0;

}

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно! Вот пример программы на языке Python, которая выводит первую и последнюю цифры четырехзначного числа 3004:

```python number = 3004

# Преобразуем число в строку для работы с отдельными цифрами number_str = str(number)

# Первая цифра - первый символ строки first_digit = int(number_str[0])

# Последняя цифра - последний символ строки last_digit = int(number_str[-1])

# Выводим результаты print("Первая цифра:", first_digit) print("Последняя цифра:", last_digit) ```

После запуска этой программы, вы получите следующий вывод:

``` Первая цифра: 3 Последняя цифра: 4 ```

Эта программа преобразует число 3004 в строку, чтобы можно было обращаться к каждой цифре как к символу строки. Затем она извлекает первый символ (первую цифру) и последний символ (последнюю цифру) строки и преобразует их обратно в целые числа для вывода на экран.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос