
Напишите программу на C ++, которая принимает число в качестве входных данных и печатает свою
таблицу умножения до 10.

Ответы на вопрос

Ответ:
#include <iostream>
#include <conio.h>
using namespace std;
int main()
{
setlocale(LC_ALL,"RUS");
int n = 0;
do{
system("CLS");
cout << "Ââåäèòå öåëîå ÷èñëî: ";
cin >> n;
for(int i = 1; i <= 10; i++){
cout << n << " * " << i << " = " << n*i << endl;
}
n = getch();
}while(n != 27);
return 0;
}



Чтобы написать программу на C++, которая принимает число в качестве входных данных и печатает таблицу умножения до 10, вам потребуется использовать циклы. В данном случае, можно использовать вложенные циклы: внешний цикл будет отвечать за число, для которого выводится таблица умножения, а внутренний цикл будет выполнять операцию умножения.
Вот пример такой программы:
```cpp
#include
int main() { int num; std::cout << "Введите число: "; std::cin >> num;
for(int i = 1; i <= 10; i++) { std::cout << num << " * " << i << " = " << num * i << std::endl; }
return 0; } ```
В этом коде:
- Сначала мы используем `std::cout` для вывода сообщения, приглашающего пользователя ввести число. - Затем мы используем `std::cin` для получения введенного пользователем числа и сохраняем его в переменной `num`. - Далее мы используем цикл `for` для итерации от 1 до 10 (включительно). На каждой итерации мы выводим строку, которая представляет собой результат умножения `num` на текущий номер итерации `i`. - В конце каждой строки мы выводим результат умножения `num * i`. - После завершения всех итераций цикла программа завершается, возвращая 0 из функции `main`, что означает успешное выполнение программы.


Похожие вопросы
Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili