Вопрос задан 04.11.2023 в 08:51. Предмет Информатика. Спрашивает Тимошенко Вика.

Составить программу, используя двумерный массив: Рассчитать сумму положительных нечетных

элементов матрицы​(Pascal)
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Хачатрян Нарек.

Ответ:

var

 a: array[,] of integer;

 m, n, i, j, sum: integer;

begin

 Write('Введите размер матрицы M и N: '); ReadLn(m, n);

 SetLength(a, m, n);

 randomize;

 WriteLn('Массив:');

 for i := 0 to m - 1 do

 begin  

   for j := 0 to n - 1 do

   begin

     a[i, j] := random(200) - 100;

     Write(a[i, j]:4);

     if (a[i, j] > 0) and (a[i, j] mod 2 = 1) then sum := sum + a[i, j];

   end;

   WriteLn;

 end;

 WriteLn('Сумма положительных нечетных элементов матрицы равна ', sum);

end.

Объяснение:

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для расчета суммы положительных нечетных элементов в двумерном массиве (матрице) на языке программирования Pascal, вы можете использовать следующий алгоритм и код:

1. Объявите двумерный массив, который представляет вашу матрицу, и заполните его значениями.

2. Создайте переменную для хранения суммы положительных нечетных элементов и инициализируйте ее нулем.

3. Используйте два вложенных цикла для перебора всех элементов матрицы.

4. Для каждого элемента матрицы проверьте, является ли он положительным и нечетным. Если да, добавьте его значение к сумме.

5. В конце программы выведите сумму положительных нечетных элементов.

Вот пример кода на Pascal, реализующий эту задачу:

```pascal program SumOfPositiveOddElements;

const Rows = 3; // Количество строк в матрице Cols = 3; // Количество столбцов в матрице

var matrix: array[1..Rows, 1..Cols] of integer; row, col, sum: integer;

begin // Заполните матрицу своими значениями // Например, случайные значения от -10 до 10 Randomize; for row := 1 to Rows do for col := 1 to Cols do matrix[row, col] := Random(21) - 10;

// Инициализация суммы sum := 0;

// Перебираем элементы матрицы for row := 1 to Rows do for col := 1 to Cols do begin if (matrix[row, col] > 0) and (matrix[row, col] mod 2 <> 0) then sum := sum + matrix[row, col]; end;

// Выводим сумму положительных нечетных элементов writeln('Сумма положительных нечетных элементов матрицы: ', sum);

readln; end. ```

Этот код создает случайную матрицу 3x3 с элементами от -10 до 10 и вычисляет сумму положительных нечетных элементов. Вы можете изменить размер матрицы и значения элементов в соответствии с вашими требованиями.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос