Написать задачу на паскале, но не как пример, который ниже. Введите с клавиатуры 8 положительных
целых чисел. Определите, сколько из них делятся на 3 и при этом заканчиваются на 4. Программа должна вывести одно число: количество чисел, кратных 3 и оканчивающихся на 4.учитель говорит, что надо НЕ ТАК, а по другому, ибо мы такое не проходили еще: var b,I:integer;a:array [1..8] of integer;beginwriteln('введите числа');for I:=1 to 8 doread(a[I]);b:=0;for I:=1 to 8 doif (a[I]mod3=0) and(a[I]mod10=4) thenb:=b+1;writeln(b);readln;end.Ответы на вопрос
program dlb;
var
x,i,counter : integer;
begin
counter := 0;
for i:= 1 to 8 do
begin
readln(x);
if (x mod 3 = 0) and (x mod 10 = 4) then
counter:= counter + 1;
end;
write(counter);
end.
Учитель правильно заметил, что код, который вы предоставили, имеет некоторые проблемы. В Pascal, чтобы прочитать 8 положительных целых чисел с клавиатуры, вам нужно использовать функцию `readln`, а не `read`. Также, чтобы убедиться, что пользователь вводит только положительные числа, вы должны включить соответствующую проверку. Вот исправленный код:
```pascal program CountNumbers; var I, b: integer; a: array[1..8] of integer;
begin writeln('Введите 8 положительных целых чисел:'); for I := 1 to 8 do begin repeat readln(a[I]); if a[I] <= 0 then writeln('Введите положительное целое число.'); until a[I] > 0; end;
b := 0; for I := 1 to 8 do begin if (a[I] mod 3 = 0) and (a[I] mod 10 = 4) then b := b + 1; end;
writeln('Количество чисел, кратных 3 и заканчивающихся на 4: ', b); readln; end. ```
Этот исправленный код сначала запрашивает 8 положительных целых чисел с клавиатуры, а затем подсчитывает количество чисел, которые делятся на 3 и оканчиваются на 4.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
