Вопрос задан 31.10.2023 в 06:46. Предмет Информатика. Спрашивает Муслимов Эмрах.

ДАЮ 100 БАЛЛОВ. ПОМОГИТЕ!! Python Дан массив d состоящий из n элементов. Найдите максимальный

элемент массива и его порядковый номер. Напишите программу.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Руткевич Анжела.

d=[]

for i in range(int(input())):

   d.append(int(input()))

print(max(d))

print(d.index(max(d)))

0 0
Отвечает Шевченко Мария.

Ответ:

В объяснении

Объяснение:

Из задания не совсем ясно, необходимо ли в программе производить ввод массиве, если нет, то решение следующее:

# Максимальный элемент массива

_max = max(d)

# Порядковый номер элемента

_index = d.index(_max)

# Вывод

print(_max, _index)

Если запрещено использовать встроенные функции, то:

# первый элемент - максимальный

_max = d[0]

_index = 0

# Цикл по всем элементам

for i, x in enumerate(d):

   # Если элемент больше максимального

   if x > _max:

       _max = x

       _index = i

# Вывод

print(_max, _index)

Если необходимо произвести и ввод, то в начале задачи надо дописать:

n = input('Введите n: ')

d = []

for x in range(n):

   d.append(input('Введите число: '))

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, я помогу вам написать программу на Python для поиска максимального элемента в массиве и определения его порядкового номера. Для этого мы можем воспользоваться циклом `for`. Вот пример кода:

```python def find_max_and_index(arr): if not arr: return None, -1 # Возвращаем None и -1, если массив пустой max_element = arr[0] # Первый элемент массива max_index = 0 # Индекс первого элемента for i in range(1, len(arr)): if arr[i] > max_element: max_element = arr[i] max_index = i return max_element, max_index

# Пример использования d = [10, 5, 8, 21, 15] max_value, index = find_max_and_index(d)

if max_value is not None: print(f"Максимальный элемент: {max_value}") print(f"Порядковый номер: {index}") else: print("Массив пустой") ```

В этом коде мы создали функцию `find_max_and_index`, которая принимает массив `arr` и возвращает максимальный элемент и его порядковый номер. Переменные `max_element` и `max_index` инициализируются первым элементом массива, а затем мы проходим по всем элементам массива, сравнивая их с текущим максимальным элементом. Если мы находим элемент, который больше текущего максимального, мы обновляем `max_element` и `max_index`. В конце выводим результат.

Учтите, что если массив пустой, программа вернет `None` в качестве максимального элемента и -1 в качестве порядкового номера.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос