Программа на паскале Заполнить линейный массив по формуле c[i]=16*x-i/9-7
Ответы на вопрос
//Версия 3.3, сборка 1611 (06.01.2018)
begin
var x:=ReadInteger('x=');
var c:=ArrGen(ReadInteger('Введите размер массива->'), i->16*x-(i+1)/9-7); c.Println;
end.
Пример:
x= 3
Введите размер массива-> 5
40.8888888888889 40.7777777777778 40.6666666666667 40.5555555555556 40.4444444444444
const
max = 42;
var
с:array[1..max]of real;
x:integer;
i:byte;
BEGIN
writeln('Заполнить линейный массив по формуле c[i]=16*x-i/9-7');
write('Введите x='); readln(x);
writeln(' ');
writeln('Массив' );
for i:=1 to max do begin
с[i]:=16*x - i/9 -7;
write(с[i], ' ');
end;
END.

Для написания программы на Паскале, которая заполняет линейный массив по формуле c[i]=16*x-i/9-7, нам понадобится объявить переменные и использовать цикл для заполнения массива.
Ниже приведен пример программы на Паскале:
```pascal program FillArray;
const n = 10; // размер массива
var c: array[1..n] of Real; // объявление массива с типом данных Real x, i: Integer; // объявление переменных x и i
begin write('Введите значение x: '); readln(x); // считываем значение x с клавиатуры // заполняем массив c по формуле for i := 1 to n do begin c[i] := 16 * x - i / 9 - 7; end; // выводим значения массива c на экран writeln('Массив c:'); for i := 1 to n do begin writeln(c[i]); end; readln; end. ```
Данная программа запрашивает у пользователя значение x, а затем заполняет массив c[n] используя формулу c[i]=16*x-i/9-7. Затем выводит значения массива на экран. В данном случае размер массива n равен 10, но его можно изменить на нужное количество элементов.
Например, если пользователь введет значение x равное 2, программа заполнит массив c следующим образом:
``` Массив c: 22 21.8888888888889 21.7777777777778 21.6666666666667 21.5555555555556 21.4444444444444 21.3333333333333 21.2222222222222 21.1111111111111 21 ```
Надеюсь, это поможет вам понять, как можно написать программу на Паскале для заполнения линейного массива по заданной формуле.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
