Вопрос задан 30.10.2023 в 21:52. Предмет Информатика. Спрашивает Волков Андрей.

Составьте программу, которая находит первую позицию пробела в строке s, А ЗАТЕМ ПРОВЕРЯЕТ, есть ли

еще пробелы в данной строке. Строка вводится с клавиатуры. паскальабс
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Величко Вика.

Ответ:

var

s: string;

i,dop: integer;

begin

writeln('Введите строку:');

readln(s);

writeln(pos(' ', s));

dop := Length(s);

for i := 1 to dop do

if s[i]=' ' then

write(' ')

end.

Если нужно вывести ВСЕ пробелы, то:

dop := Length(s);

for i := 1 to dop do

if s[i]=' ' then

write(' ')

end.

Проверка на наличие 2+ пробелов (размещать в конце (перед end.)):

if i > 3 then

 write('Пробелы ещё есть')

else

 writeln('Пробелов больше нет');

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вот пример программы на языке Pascal, которая находит первую позицию пробела в строке и затем проверяет, есть ли еще пробелы в данной строке:

``` program FindSpaces; var s: string; firstSpacePos: integer; hasSpaces: boolean; i: integer; begin // Ввод строки с клавиатуры writeln('Введите строку:'); readln(s); // Находим первую позицию пробела в строке firstSpacePos := pos(' ', s); // Проверяем, есть ли еще пробелы в строке hasSpaces := false; for i := 1 to length(s) do begin if s[i] = ' ' then begin hasSpaces := true; break; end; end; // Вывод результата writeln('Первая позиция пробела в строке: ', firstSpacePos); if hasSpaces then writeln('В данной строке есть еще пробелы') else writeln('В данной строке нет больше пробелов'); end. ```

Программа сначала запрашивает у пользователя ввод строки с клавиатуры. Затем она находит первую позицию пробела в строке с помощью функции `pos()`. Далее происходит проверка наличия других пробелов в строке с помощью цикла и условного оператора. Результат выводится на экран с помощью процедуры `writeln()`.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос