Вопрос задан 30.10.2023 в 02:05.
Предмет Информатика.
Спрашивает Ivanova Karina.
Помогите написать программу на с++!!! В данной строке удвоить все цифры и малые латинские буквы.
срочно!!Ответы на вопрос
Отвечает Яковлева Диана.
#include <iostream>
#include <string>
using namespace std;
bool isb(char t)
{
bool f=false;
string dic="abcdefghijklmnopqrstuvwxyz1234567890";
for(int i=0;i<dic.size();i++)
if(dic[i]==t)
return !f;
return f;
}
int main()
{
string s;
int i=0;
getline(cin,s);
while(i<s.size())
{
if(isb(s[i]))
{
s.insert(i,1,s[i]);
i++;
}
i++;
}
cout<<s<<endl;
return 0;
}
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, я могу помочь вам написать программу на языке C++ для удвоения всех цифр и малых латинских букв в строке. Вот пример кода:
```cpp
#include
#include
std::string doubleDigitsAndLetters(const std::string& str) {
std::string result;
for (char ch : str) {
if (isdigit(ch) || islower(ch)) {
result += ch;
result += ch;
} else {
result += ch;
}
}
return result;
}
int main() {
std::string input;
std::cout << "Введите строку: ";
std::getline(std::cin, input);
std::string result = doubleDigitsAndLetters(input);
std::cout << "Результат: " << result << std::endl;
return 0;
}
```
Программа использует функцию `doubleDigitsAndLetters`, которая принимает входную строку и возвращает новую строку с удвоенными цифрами и малыми латинскими буквами. В функции происходит обход каждого символа входной строки, и если символ является цифрой или малой латинской буквой, то он добавляется дважды в результирующую строку. Иначе символ добавляется один раз.
В функции `main` программа считывает входную строку с помощью `std::getline` и передает ее в функцию `doubleDigitsAndLetters`. Затем она выводит полученный результат на экран.
Вы можете скопировать этот код в IDE для языка C++ (например, Code::Blocks, Visual Studio) или использовать онлайн-компиляторы для выполнения этой программы.
0
0
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 31
Информатика 25
Информатика 101
Информатика 14
Информатика 501
Информатика 52
Информатика 42
Информатика 238
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
