Вопрос задан 07.06.2023 в 08:07. Предмет Информатика. Спрашивает Александр Литвинов.

Написать программу на Python!!! СТРОКИ в python.Предоставлен словарь. 1. сначала произнесите

третью букву этого слова.2. во второй строке отделите букву перед буквой В конце этого слова. 3.вытяните первые пять букв в третьей строке. 4.в четвертой строке вычтите все буквы, кроме последних двух. 5. в пятой строке вычеркните пару индексных букв. 6. в шестой строке вычеркните Буквы в точном индексе. 7. в седьмой строке напишите слово наоборот. 8. в восьмой строке оставьте по одной букве, начиная с обратной стороны слова.9. определите длину этого слова в девятой строке. 10. создайте программу, которая определяет, сколько разных букв в данном слове? например: Kirgizistan--------> i bukva 3
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Кисарова Настя.

Ответ:

word = input("Введите слово: ")

# 1. произнесите третью букву этого слова.

third_letter = word[2]

print("Третья буква:", third_letter)

# 2. отделите букву перед буквой В конце этого слова.

second_line = word[:-2].split()[-1][-1]

print("Предпоследняя буква:", second_line)

# 3. вытяните первые пять букв в третьей строке.

third_line = word[:5]

print("Первые пять букв:", third_line)

# 4. вычтите все буквы, кроме последних двух.

fourth_line = word[-2:]

print("Последние две буквы:", fourth_line)

# 5. вычеркните пару индексных букв.

fifth_line = word[:2] + word[4:]

print("Буквы без третьей и четвертой:", fifth_line)

# 6. вычеркните Буквы в точном индексе.

sixth_line = ""

for i in range(len(word)):

   if i not in [1, 3, 5]:

       sixth_line += word[i]

print("Буквы без 2, 4 и 6:", sixth_line)

# 7. напишите слово наоборот.

seventh_line = word[::-1]

print("Слово наоборот:", seventh_line)

# 8. оставьте по одной букве, начиная с обратной стороны слова.

eighth_line = word[::-2]

print("Каждая вторая буква в обратном порядке:", eighth_line)

# 9. определите длину этого слова.

ninth_line = len(word)

print("Длина слова:", ninth_line)

# 10. определите количество разных букв в слове.

unique_letters = set(word)

tenth_line = len(unique_letters)

print("Количество разных букв:", tenth_line)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на Python, выполняющей указанные операции со строкой:

python
word = "Kirgizistan" # 1. Третья буква third_letter = word[2] print("1. Третья буква:", third_letter) # 2. Буква перед "В" before_v = word[word.index("В") - 1] print("2. Буква перед 'В':", before_v) # 3. Первые пять букв first_five = word[:5] print("3. Первые пять букв:", first_five) # 4. Последние две буквы last_two = word[-2:] print("4. Последние две буквы:", last_two) # 5. Вычеркнуть пару индексных букв removed_pair = word[:2] + word[4:] print("5. Вычеркнутая пара индексных букв:", removed_pair) # 6. Вычеркнуть буквы в точном индексе indices_to_remove = [1, 3, 5] removed_letters = ''.join([char for i, char in enumerate(word) if i not in indices_to_remove]) print("6. Вычеркнутые буквы в точном индексе:", removed_letters) # 7. Слово наоборот reversed_word = word[::-1] print("7. Слово наоборот:", reversed_word) # 8. По одной букве с обратной стороны слова reverse_letters = word[::-1][::2] print("8. По одной букве с обратной стороны слова:", reverse_letters) # 9. Длина слова word_length = len(word) print("9. Длина слова:", word_length) # 10. Количество разных букв в слове unique_letters = len(set(word)) print("10. Количество разных букв в слове:", unique_letters)

Эта программа выполняет указанные операции со строкой "Kirgizistan" и выводит результаты каждой операции.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос