
Напишите программу, которая по введённому числу определит, какое сейчас время суток. Будем
считать, что если введено число от 5 до 10, то это утро, от 11 до 17, то день, с 18 до 22 – вечер, с 23 до 4 – ночь. Предусмотрите, что пользователь может ввести неверное число или вообще слово. Тогда ему стоит написать: Ошибка. Не забудьте, что в данной задаче числа – это тоже строки. Формат ввода Вводится строка. Формат вывода Если введено число от 5 до 10, то вывести Утро, от 11 до 17, то День, с 18 до 22 – Вечер, с 23 до 4 – Ночь. Если введено неверное число или слово, то вывести: Ошибка.

Ответы на вопрос

var
s:string[2];
r,c:integer;
begin
readln(s);
val(s,c,r);
if (r<>0) or (c>24) or (c<0) then
begin
writeln('Error');
exit;
end
else
case c of
5..10: writeln('ytro');
11..17: writeln('den');
18..22: writeln('vecher')
else writeln('noch');
end;
end.



Для решения этой задачи, вы можете написать программу на Python. Вот пример такой программы:
```python # Запрашиваем у пользователя ввод input_str = input("Введите время: ")
# Проверяем, является ли введенная строка числом if input_str.isdigit(): # Преобразуем строку в число time = int(input_str) # Проверяем, в каком диапазоне находится введенное число if 5 <= time <= 10: print("Утро") elif 11 <= time <= 17: print("День") elif 18 <= time <= 22: print("Вечер") elif time >= 23 or time <= 4: print("Ночь") else: print("Ошибка") else: print("Ошибка") ```
Этот код сначала запрашивает у пользователя ввод, затем проверяет, является ли введенная строка числом с помощью метода `isdigit()`. Если введенная строка - число, то она преобразуется в целое число, и затем проверяется, в каком из указанных диапазонов находится число, после чего выводится соответствующее время суток. Если введенная строка не является числом, или число не попадает в указанные диапазоны, программа выводит "Ошибка".



Для решения данной задачи можно использовать условные операторы и конструкцию if-elif-else.
Программа будет запрашивать у пользователя ввод числа или слова. Затем, используя условия, она будет проверять, в какой временной промежуток попадает введенное значение и выводить соответствующее время суток.
Пример решения на языке Python:
```python value = input("Введите число или слово: ")
if value.isdigit(): # если введено число value = int(value) # преобразуем строку в число для сравнения
if 5 <= value <= 10: print("Утро") elif 11 <= value <= 17: print("День") elif 18 <= value <= 22: print("Вечер") else: print("Ночь") else: print("Ошибка") # если введено неверное число или слово ```
В данной программе мы сначала преобразуем введенную строку в число с помощью функции `int()`. Затем сравниваем полученное число с условиями: если оно попадает в определенный временной промежуток, программа выводит соответствующую строку. Если введено неверное число или слово, выводится сообщение "Ошибка".


Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili