Напишите программу на С++, которая заменяет в символьной строке все буквы a на буквы b (латинские,
строчные). Решение с комментариями к каждой строке кода. Комментарии должны пояснять, что происходит в каждой строке программы, для чего она нужна и т.п. Входные данные Входная строка содержит символы латинского алфавита, как строчные, так и заглавные. Выходные данные Программа должна заменить во всей строке строчные буквы a на буквы b и вывести в первой строке получившуюся символьную строку, а во второй – количество выполненных замен. Примеры входные данные aabbccabadef выходные данные bbbbccbbbdef 4Ответы на вопрос
Ответ:
#include <iostream>
int main()
{
char str[80]; // Объявление символьной строки
int i = 0, cnt = 0; // Объявление переменных i и cnt целого типа - счетчик для цикла
// и переменная, в которой будем считать кол-во замен
std::cin >> str; // Считывание строки из консоли в символьную строку str
while (str[i] != '\0') // Пока очередной символ не станет равен символу конца строки
{
if (str[i] == 'a')
{
str[i] = 'b'; // Заменяем символ 'a' на символ 'b'
cnt++; // Увеличиваем счетчик замен на единицу
}
i++; //переходим к следующему символу
}
std::cout << str << std::endl; // Выводим измененную символьную строку на экран
std::cout << cnt; // Выводим количество замен
return 0;
}
Вот пример программы на C++, которая выполняет задачу замены букв в строке и подсчета количества замен:
cpp#include <iostream>
#include <string>
int main() {
std::string inputString;
std::cout << "Введите строку: ";
std::getline(std::cin, inputString); // Ввод строки
int replacements = 0; // Счетчик замен
for (char &ch : inputString) {
if (ch == 'a') {
ch = 'b';
replacements++; // Увеличиваем счетчик замен
}
}
std::cout << "Измененная строка: " << inputString << std::endl;
std::cout << "Количество замен: " << replacements << std::endl;
return 0;
}
Комментарии к каждой строке программы:
#include <iostream>: Подключение библиотеки для работы с вводом/выводом.#include <string>: Подключение библиотеки для работы со строками.int main() {: Начало функцииmain.std::string inputString;: Объявление переменнойinputStringдля хранения введенной строки.std::cout << "Введите строку: ";: Вывод приглашения пользователю ввести строку.std::getline(std::cin, inputString);: Считывание строки, введенной пользователем, в переменнуюinputString.int replacements = 0;: Объявление и инициализация счетчика замен.for (char &ch : inputString) {: Начало цикла по символам во введенной строке.if (ch == 'a') {: Проверка, является ли текущий символ буквой 'a'.ch = 'b';: Если символ 'a', то заменяем его на 'b'.replacements++;: Увеличиваем счетчик замен.std::cout << "Измененная строка: " << inputString << std::endl;: Вывод измененной строки.std::cout << "Количество замен: " << replacements << std::endl;: Вывод количества замен.return 0;: Завершение функцииmain.
Эта программа позволяет пользователю ввести строку, заменяет все строчные буквы 'a' на 'b', выводит измененную строку и количество выполненных замен.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
