Вопрос задан 29.10.2023 в 22:18. Предмет Информатика. Спрашивает Урюпина Анастасия.

Напишите программу в pascal Задаются границы диапазонанайти сумму тех чисел которые четные

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Каралов Тёма.

var a,b,i,z,x:integer;

q:array [1..20] of integer;

begin

 write('Верхняя граница='); readln(a);

 write('Нижняя граница='); readln(b); x:=a-b; randomize;

 for i:=1 to 20 do

 begin  

   q[i]:=random(x)+b;

   write(q[i],' ');

   if (q[i]mod 2=0) then z:=z+q[i];

 end;

 writeln;

 write('Сумма четных чисел=',z);

end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Вот пример программы на языке Pascal, которая находит сумму четных чисел в заданном диапазоне: ```pascal program SumOfEvenNumbers; var lowerBound, upperBound, num, sum: integer; begin // Ввод границ диапазона writeln('Введите нижнюю границу диапазона:'); readln(lowerBound); writeln('Введите верхнюю границу диапазона:'); readln(upperBound); sum := 0; // Изначально сумма равна 0 // Проверяем каждое число в диапазоне for num := lowerBound to upperBound do begin // Если число четное, добавляем его к сумме if num mod 2 = 0 then sum := sum + num; end; // Выводим результат writeln('Сумма четных чисел в диапазоне от ', lowerBound, ' до ', upperBound, ' равна ', sum); readln; end. ``` В этой программе мы сначала запрашиваем у пользователя нижнюю и верхнюю границы диапазона. Затем мы создаем переменную `sum` и задаем ей изначальное значение 0. Далее мы используем цикл `for`, чтобы проверить каждое число в диапазоне от `lowerBound` до `upperBound`. Если число делится нацело на 2 (т.е. оно четное), мы добавляем его к сумме. В конце программы мы выводим результат - сумму четных чисел в заданном диапазоне.
0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос