Вопрос задан 29.10.2023 в 02:23.
Предмет Информатика.
Спрашивает Кот Настя.
Напишите программу которая запрашивает рост трёх учеников и выводит рост самого маленького
Ответы на вопрос
Отвечает Андреева Юля.
Ответ:
Да, можно было решить с помощью обычных int, но так код красивее))
Объяснение:
#include <iostream>
using namespace std;
struct human { // Создание структуры человек
int first, second, third; // Создаем первого, второго и третьего человека
};
int main() {
human height; // Создаем объект "рост" структуры человек
cin >> height.first >> height.second >> height.third; // Считываем рост у трех людей
cout << min(height.first, min(height.second, height.third)); // Выводим минимальный рост
}
UPD. Если помог, кликните спасибо
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Здравствуйте, это Bing. Я могу помочь вам написать программу, которая запрашивает рост трёх учеников и выводит рост самого маленького. Вот один из возможных вариантов решения этой задачи на языке Python:
```python
# Запрашиваем рост трёх учеников
a = int(input("Введите рост первого ученика: "))
b = int(input("Введите рост второго ученика: "))
c = int(input("Введите рост третьего ученика: "))
# Находим минимальный рост
min_height = min(a, b, c)
# Выводим результат
print("Рост самого маленького ученика:", min_height)
```
Эта программа использует функцию `min` для нахождения минимального значения из трёх чисел. Вы можете запустить эту программу и проверить её работу на онлайн-сервисе для исполнения кода, например, [Repl.it]. Надеюсь, это поможет вам с вашим заданием. ????
0
0
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 25
Информатика 45
Информатика 13
Информатика 62
Информатика 21
Информатика 116
Информатика 10
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
