Вопрос задан 07.08.2023 в 00:26.
Предмет Информатика.
Спрашивает Батурин Богдан.
1. Составьте программу, которая запрашивает с клавиатуры значения x и y.
Если x>y то печатается разность x-y, в противном случае y-x. 2. Напишите программу, которая запрашивает с клавиатуры a, b, c. Если a>b+c, то на печать выводится a. В другом случае выводится b+c.3. Напишите программу, которая запрашивает с клавиатуры значения k и x. Если k=1, то вычисляется значение sin(x), если k=2, то вычисляется значение cos(x).4. Напишите программу, которая запрашивает значения p и m. Если p>m2 , то печатается p, в противном случае m2.СДЕЛАЙТЕ В ПАСКАЛЕ)И МОЖЕТЕ МЕНЯ НАУЧИТЬ ?Ответы на вопрос
Отвечает Павлюк Руслан.
//Pascal
//1)
var x, y: integer;
begin
write('Введите x y: ');
read(x, y);
if x > y then
writeln(x - y)
else
writeln(y - x);
end.
//2)
var a, b, c: integer;
begin
write('Введите a b c: ');
read(a, b, c);
if (a > (b + c)) then
writeln(a)
else
writeln(b + c);
end.
//3)
var x, k: integer;
begin
write('Введите x k: ');
read(x, k);
if k = 1 then
writeln(sin(x))
else
if k = 2 then
writeln(cos(x))
else
writeln('k должен быть равен 1 или 2.');
end.
//4)
var p, m: integer;
begin
write('Введите p, m: ');
read(p, m);
if p > m * 2 then
writeln(p)
else
writeln(m * 2);
end.
//1)
var x, y: integer;
begin
write('Введите x y: ');
read(x, y);
if x > y then
writeln(x - y)
else
writeln(y - x);
end.
//2)
var a, b, c: integer;
begin
write('Введите a b c: ');
read(a, b, c);
if (a > (b + c)) then
writeln(a)
else
writeln(b + c);
end.
//3)
var x, k: integer;
begin
write('Введите x k: ');
read(x, k);
if k = 1 then
writeln(sin(x))
else
if k = 2 then
writeln(cos(x))
else
writeln('k должен быть равен 1 или 2.');
end.
//4)
var p, m: integer;
begin
write('Введите p, m: ');
read(p, m);
if p > m * 2 then
writeln(p)
else
writeln(m * 2);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, я могу помочь вам с написанием этих программ на языке Pascal. Ниже приведены листинги программ для каждой из задач:
Программа 1:
pascalprogram Program1; var x, y: Integer; begin Write('Введите значение x: '); Readln(x); Write('Введите значение y: '); Readln(y); if x > y then writeln('Разность x - y: ', x - y) else writeln('Разность y - x: ', y - x); end.
Программа 2:
pascalprogram Program2; var a, b, c: Integer; begin Write('Введите значение a: '); Readln(a); Write('Введите значение b: '); Readln(b); Write('Введите значение c: '); Readln(c); if a > b + c then writeln('Значение a: ', a) else writeln('Сумма b + c: ', b + c); end.
Программа 3:
pascalprogram Program3; var k: Integer; x: Real; begin Write('Введите значение k (1 или 2): '); Readln(k); Write('Введите значение x: '); Readln(x); if k = 1 then writeln('sin(x) = ', sin(x)) else if k = 2 then writeln('cos(x) = ', cos(x)) else writeln('Некорректное значение k.'); end.
Программа 4:
pascalprogram Program4; var p, m: Integer; begin Write('Введите значение p: '); Readln(p); Write('Введите значение m: '); Readln(m); if p > sqr(m) then writeln('Значение p: ', p) else writeln('Квадрат m: ', sqr(m)); end.
Чтобы использовать эти программы, вам нужно скопировать соответствующий код в среду разработки Pascal (например, Free Pascal) и запустить его там. Если у вас есть вопросы по коду или по программированию на Pascal, не стесняйтесь спрашивать!
Похожие вопросы
Информатика 11
Информатика 41
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
