Вопрос задан 28.10.2023 в 23:09. Предмет Информатика. Спрашивает Маслий Владислав.

Какую(ие) операцию(ии) на языке pascal надо применить,чтобы определить сколько: 1) сколько полных

метров в x миллиметрах 2)сколько единиц в шестизначном числе m3)сколько сотен в семизначном числе k4)сколько полных тонн в y центнерах5)сколько единиц в семизначном числе n6)сколько тысяч в шестизначном числе f​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Луканина Инна.

Ответ:

1) div (деление без остатка)

2) mod (остаток от деления) и div, for(перечисление)

3) mod и div

4) div

5) for, div, mod

6)div mod

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для выполнения этих операций на языке Pascal, вы можете использовать операторы деления и остатка от деления. Вот как это можно сделать для каждой из задач: 1) Сколько полных метров в x миллиметрах: ```pascal var x, meters: integer; begin // Ввод значения x (миллиметры) с клавиатуры или другим способом // Затем вычислите количество метров meters := x div 1000; writeln('Полных метров в ', x, ' миллиметрах: ', meters); end. ``` 2) Сколько единиц в шестизначном числе m: ```pascal var m, units: integer; begin // Ввод значения m (шестизначное число) с клавиатуры или другим способом // Затем вычислите количество единиц units := m mod 10; writeln('Единиц в числе ', m, ': ', units); end. ``` 3) Сколько сотен в семизначном числе k: ```pascal var k, hundreds: integer; begin // Ввод значения k (семизначное число) с клавиатуры или другим способом // Затем вычислите количество сотен hundreds := (k div 100) mod 10; writeln('Сотен в числе ', k, ': ', hundreds); end. ``` 4) Сколько полных тонн в y центнерах: ```pascal var y, tons: integer; begin // Ввод значения y (центнеры) с клавиатуры или другим способом // Затем вычислите количество полных тонн tons := y div 10; writeln('Полных тонн в ', y, ' центнерах: ', tons); end. ``` 5) Сколько единиц в семизначном числе n (то же, что и в задаче 2): ```pascal var n, units: integer; begin // Ввод значения n (семизначное число) с клавиатуры или другим способом // Затем вычислите количество единиц units := n mod 10; writeln('Единиц в числе ', n, ': ', units); end. ``` 6) Сколько тысяч в шестизначном числе f: ```pascal var f, thousands: integer; begin // Ввод значения f (шестизначное число) с клавиатуры или другим способом // Затем вычислите количество тысяч thousands := (f div 1000) mod 10; writeln('Тысяч в числе ', f, ': ', thousands); end. ``` В каждом из этих примеров мы используем операторы деления `div` и остатка от деления `mod`, чтобы выполнить необходимые вычисления.
0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос