Составить программу для задачи: Ввести трехзначное число, и вывести через запятую его отдельные
цифры.PascalОтветы на вопрос
Внимание! Если программа не работает, обновите версию!
1. Самое простое "арифметическое" решение
begin
var n:=Abs(ReadInteger('n=')); // защита от отрицательных чисел
Writeln(n div 100,',',(n div 10) mod 10,',',n mod 10)
end.
Пример
n= 318
3,1,8
2. "Арифметическое" решение с циклом, цифры в обратном порядке
begin
var n:=Abs(ReadInteger('n=')); // защита от отрицательных чисел
while n>10 do begin
Write(n mod 10,',');
n:=n div 10
end;
Writeln(n mod 10)
end.
Пример
n= 318
8,1,3
3. "Арифметическое" решение с массивом
begin
var n:=Abs(ReadInteger('n=')); // защита от отрицательных чисел
var a:array[1..3] of integer;
var i:=3;
while n>0 do begin
a[i]:=n mod 10;
i-=1;
n:=n div 10
end;
Writeln(a[1],',',a[2],',',a[3])
end.
Пример
n= 318
3,1,8
4. Решение с символьной строкой
begin
Abs(ReadInteger('n=')).ToString.ToCharArray.Println(',')
end.
Пример
n= 318
3,1,8
Программа на языке Pascal, которая вводит трехзначное число и выводит его цифры через запятую, может выглядеть следующим образом:
```pascal program SeparateDigits; var number, digit1, digit2, digit3: integer; // объявляем переменные begin // вводим трехзначное число writeln('Введите трехзначное число:'); readln(number); // вычисляем отдельные цифры числа digit1 := number div 100; // первая цифра digit2 := (number div 10) mod 10; // вторая цифра digit3 := number mod 10; // третья цифра // выводим цифры через запятую writeln('Отдельные цифры числа:'); write(digit1, ',', digit2, ',', digit3); // задержка перед закрытием программы readln; end. ```
Программа начинается с объявления переменных `number`, `digit1`, `digit2` и `digit3`, которые будут использоваться для хранения введенного числа и его отдельных цифр.
Затем пользователю предлагается ввести трехзначное число с помощью функции `writeln('Введите трехзначное число:');` и `readln(number);`.
Далее, с помощью выражений `digit1 := number div 100;`, `digit2 := (number div 10) mod 10;` и `digit3 := number mod 10;` вычисляются отдельные цифры числа и сохраняются в соответствующих переменных.
Наконец, с помощью функции `writeln('Отдельные цифры числа:'); write(digit1, ',', digit2, ',', digit3);` выводятся отдельные цифры чисел через запятую.
В конце программы добавлена команда `readln;`, чтобы программа не закрывалась сразу после вывода результатов и пользователю дали возможность прочитать результаты до закрытия программы.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
