Составить программу вывода на экран среднего арифметического массива состоящего из 15 элементов
Ответы на вопрос
const
n=15;
var
a:array [1..n] of integer;
i,b:integer;
begin
randomize;
for i:=1 to n do begin
a[i]:=random (20);
a[i]:=a[i]-10;
writeln(i,' ',a[i]);
end;
b:=0;
for i:=1 to n do
b:=b+a[i];
writeln('srednee = ',b/n);
readln;
end.
Для составления программы на вывод среднего арифметического массива из 15 элементов, вам потребуется язык программирования. Я предоставлю вам пример программы на Python, одном из самых популярных языков программирования.
```python # Создаем массив с 15 элементами arr = [10, 20, 30, 40, 50, 60, 70, 80, 90, 100, 110, 120, 130, 140, 150]
# Вычисляем сумму всех элементов массива total = sum(arr)
# Вычисляем среднее арифметическое average = total / len(arr)
# Выводим результат на экран print("Среднее арифметическое массива:", average) ```
В этом примере мы создаем массив `arr`, состоящий из 15 элементов. Затем мы используем функцию `sum()` для вычисления суммы всех элементов массива, и делим эту сумму на количество элементов в массиве с помощью `len(arr)`, чтобы найти среднее арифметическое. Наконец, мы выводим результат на экран с помощью функции `print()`.
Вы можете изменить значения в массиве `arr`, чтобы подставить свои собственные данные. Эта программа будет работать с любым массивом из 15 чисел.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
