Вопрос задан 27.10.2023 в 13:03. Предмет Информатика. Спрашивает Нерода Арина.

ПАСКАЛЬ. Написать программу, которая считает количество буквы в строке. Допустим букву "а" в любом

регистре, строка вводится с клавиатуры. входной файл: предложение выходной файл: количество буквы Я просто немного понять не могу, как счетчик вести с символами. Помогите пожалуйста.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Дугаров Очир.

PascalABC.NET 3.4.2, сборка 1864 от 11.11.2018

Внимание! Если программа не работает, обновите версию!

begin

 ReadlnString.MatchValues('[аА]').Count.Println

end.

Пример

А роза упала на лапу Азора

8

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Решение на языке программирования Pascal

Для подсчета количества буквы в строке на языке Pascal можно использовать следующий код:

```pascal program CountLetter;

var sentence: string; letter: char; count: integer; i: integer;

begin // Ввод строки с клавиатуры writeln('Введите предложение:'); readln(sentence);

// Ввод буквы с клавиатуры writeln('Введите букву:'); readln(letter);

// Инициализация счетчика count := 0;

// Подсчет количества буквы в строке for i := 1 to length(sentence) do begin if (sentence[i] = letter) or (sentence[i] = UpCase(letter)) or (sentence[i] = LoCase(letter)) then count := count + 1; end;

// Вывод результата writeln('Количество буквы "', letter, '" в предложении: ', count); end. ```

В этом коде мы сначала запрашиваем у пользователя ввод предложения и буквы с клавиатуры. Затем мы инициализируем счетчик `count` значением 0 и используем цикл `for` для перебора всех символов в строке `sentence`. Внутри цикла мы проверяем, является ли текущий символ равным введенной букве `letter` в любом регистре. Если это так, мы увеличиваем счетчик `count` на 1. В конце программы мы выводим результат подсчета.

Пример использования:

``` Введите предложение: Привет, как дела? Введите букву: а Количество буквы "а" в предложении: 2 ```

Надеюсь, это поможет вам понять, как вести счетчик с символами в языке Pascal. Если у вас возникнут дополнительные вопросы, пожалуйста, дайте мне знать!

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос