Написать программу, которая определяет в одномерном массиве, заполненном случайным образом,
количество элементов, значения которых меньше числа, введенного с клавиатуры. Если есть, то вывести эти элементыОтветы на вопрос
const n=17;
var a: array[1..n] of integer;
i,c,k: integer;
begin
randomize;
write('введите число: ');
readln(c);
writeln('массив: ');
for i:=1 to n do
begin
a[i]:=random(50);
write(a[i],' ');
end;
writeln;
writeln('эл. которые меньше ',c);
for i:=1 to n do if a[i]<c then
begin
k:=k+1;
write(a[i],' ');
end;
writeln;
writeln('количество: ',k);
end.
Для решения данной задачи можно написать программу на языке программирования, которая будет определять количество элементов в одномерном массиве, значения которых меньше числа, введенного с клавиатуры. Затем программа выведет эти элементы.
Вот пример программы на языке C++:
```cpp
#include
int main() { int n; std::cout << "Введите количество элементов в массиве: "; std::cin >> n;
std::vector
int number; std::cout << "Введите число: "; std::cin >> number;
std::vector
std::cout << "Элементы, меньше числа " << number << ": "; for (int i = 0; i < smallerElements.size(); i++) { std::cout << smallerElements[i] << " "; } std::cout << std::endl;
return 0; } ```
Эта программа сначала запрашивает количество элементов в массиве, затем заполняет массив значениями, введенными с клавиатуры. Затем программа запрашивает число и находит элементы массива, которые меньше этого числа. Найденные элементы выводятся на экран.
Примечание: В данном примере используется вектор из стандартной библиотеки C++, чтобы упростить работу с массивом переменной длины. Если вы хотите использовать обычный массив, вам нужно будет изменить код соответствующим образом.
Надеюсь, это поможет вам решить задачу! Если у вас возникнут дополнительные вопросы, пожалуйста, дайте мне знать.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
