Составить программу в паскале, в которой: а) неотрицательные числа заменить sqr, а отрицательные
заменить числом 12345. б) Подсчитать и вывести отрицательные элементы массиваОтветы на вопрос
FPC IDE 2.6.0
var a,b:array[1..10] of integer; i,k,z:integer;
begin z:=1;
for i:=1 to 10 do
begin
a[i]:=random(25)-15;
if a[i]>0 then a[i]:=sqr(a[i]);
if a[i]<0 then begin b[z]:=a[i]; a[i]:=12345; inc(k); inc(z); end;
end;
for i:=1 to 10 do
writeln('a[',i,']=',a[i]);
writeln('Kol-vo otricatelnux: ',z-1);
for i:=1 to z-1 do writeln('Otricatelnie elementy: ',b[i]);
readln;
end.
Программа в Паскале для замены чисел в массиве
Для решения данной задачи, можно написать программу на языке Паскаль, которая заменяет неотрицательные числа в массиве на квадраты этих чисел, а отрицательные числа на число 12345. Затем программа подсчитывает и выводит отрицательные элементы массива.
Вот пример программы на Паскале, решающей данную задачу:
```pascal program ReplaceNumbers;
const N = 10; // размер массива
var arr: array[1..N] of Integer; i: Integer;
begin // Заполняем массив случайными числами Randomize; for i := 1 to N do arr[i] := Random(100) - 50; // генерируем числа от -50 до 49
// Выводим исходный массив writeln('Исходный массив:'); for i := 1 to N do write(arr[i], ' '); writeln;
// Заменяем числа в массиве for i := 1 to N do begin if arr[i] >= 0 then arr[i] := sqr(arr[i]) // заменяем неотрицательные числа на их квадрат else arr[i] := 12345; // заменяем отрицательные числа на 12345 end;
// Выводим измененный массив writeln('Измененный массив:'); for i := 1 to N do write(arr[i], ' '); writeln;
// Подсчитываем и выводим отрицательные элементы массива writeln('Отрицательные элементы массива:'); for i := 1 to N do begin if arr[i] < 0 then write(arr[i], ' '); end; writeln;
readln; end. ```
В данной программе: - Мы объявляем массив `arr` размером `N` и переменную `i` для циклов. - Заполняем массив случайными числами от -50 до 49. - Выводим исходный массив. - Заменяем неотрицательные числа в массиве на их квадрат, а отрицательные числа на 12345. - Выводим измененный массив. - Подсчитываем и выводим отрицательные элементы массива.
Примечание: В данной программе мы использовали функцию `sqr`, которая возвращает квадрат числа. Эта функция доступна в языке Паскаль.
Надеюсь, данная программа поможет вам решить задачу! Если у вас возникнут дополнительные вопросы, не стесняйтесь задавать.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
