
Составить программу, определяющую, является ли введённое с клавиатуры число простым. Если простое
вывести да, если нет соответственно нет. Это если что ПАСКАЛЬ.

Ответы на вопрос

PascalABC.NET 3.4.2, сборка 1837 от 11.10.2018
function IsPrime(self: integer): boolean; extensionmethod;
begin
Result := true;
for var i := 2 to floor(sqrt(self)) do
if self mod i = 0 then begin result := false; exit; end;
end;
begin
Println(ReadInteger.IsPrime ? 'Да' : 'Нет')
end.



Да, конечно! Вот пример программы на Pascal, которая определяет, является ли введенное с клавиатуры число простым:
```pascal program CheckPrimeNumber; var num, i: integer; isPrime: boolean; begin writeln('Введите число: '); readln(num); // Инициализируем переменную isPrime значением true isPrime := true; // Проверяем, является ли число num простым if num < 2 then isPrime := false else begin for i := 2 to trunc(sqrt(num)) do begin if (num mod i) = 0 then begin isPrime := false; break; end; end; end; // Выводим результат if isPrime then writeln('Да, число ', num, ' является простым.') else writeln('Нет, число ', num, ' не является простым.'); end. ```
В этой программе сначала запрашивается ввод числа с клавиатуры (`num`). Затем переменная `isPrime` инициализируется значением `true`, предполагая, что число простое.
Затем происходит проверка: если `num` меньше 2, то оно не является простым. В противном случае, программа использует цикл для проверки делимости числа на все числа от 2 до квадратного корня из `num`. Если находится хотя бы один делитель, то `num` не является простым, и переменная `isPrime` становится `false`.
Наконец, программа выводит соответствующее сообщение в зависимости от результата проверки.
Например, если вы введете число 17, программа выведет "Да, число 17 является простым." Если введете число 12, то выведет "Нет, число 12 не является простым.".


Похожие вопросы







Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili