
Помогите пожалуйста!!! В паскале!! Составить программу в которой значение каждого элемента массива
равно раннее введённому значению минус порядковый номер

Ответы на вопрос





Конечно, вот пример программы на языке Pascal, которая создает массив и заполняет его значениями, равными введенному числу минус порядковый номер:
```pascal program ArrayProgram;
var inputNumber, i: integer; arraySize: integer; arr: array of integer;
begin // Запрашиваем у пользователя размер массива writeln('Введите размер массива: '); readln(arraySize);
// Запрашиваем у пользователя число, которое будет использоваться для заполнения массива writeln('Введите число: '); readln(inputNumber);
// Выделяем память под массив SetLength(arr, arraySize);
// Заполняем массив значениями, равными введенному числу минус порядковый номер for i := 0 to arraySize - 1 do begin arr[i] := inputNumber - i; end;
// Выводим массив на экран writeln('Массив:'); for i := 0 to arraySize - 1 do begin writeln(arr[i]); end; end. ```
Эта программа сначала запрашивает у пользователя размер массива и число, которое будет использоваться для заполнения массива. Затем она создает и заполняет массив значениями, равными введенному числу минус порядковый номер. В конце программа выводит полученный массив на экран.


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili