Вопрос задан 23.10.2023 в 16:13.
Предмет Информатика.
Спрашивает Chistyakov Maksim.
Написать программу в с++, которая по номеру месяца выводит коли- чество дней в нем в не
високосном году.Предусмотреть вывод сообщения об ошибке в случае неправильных входных данных.Ответы на вопрос
Отвечает Самохвалова Полина.
//Изи
объявляешь библиотеки
int main(){
// УСКОРЯЕТ ВВОД
ios_base::sync_with_stdio(false);
cin.tie(0);
//Программа
int n;
vector<int> v={31,28,31,30,31,30,31,31,30,31,30,31};
while(cin >> n;) {cout << v[n-1]; } // считывание пока вводим
return 0;}
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Вот пример программы на C++, которая выполняет задачу, о которой вы спрашиваете:
cpp#include <iostream>
int main() {
int month;
std::cout << "Введите номер месяца (1-12): ";
std::cin >> month;
if (month >= 1 && month <= 12) {
int days;
if (month == 2) {
days = 28; // Февраль имеет 28 дней в невисокосном году
} else if (month == 4 || month == 6 || month == 9 || month == 11) {
days = 30; // Месяцы с 30 днями
} else {
days = 31; // Остальные месяцы
}
std::cout << "В месяце " << month << " " << days << " дней." << std::endl;
} else {
std::cout << "Ошибка: введите правильный номер месяца (1-12)." << std::endl;
}
return 0;
}
Эта программа запрашивает у пользователя номер месяца и затем использует условные операторы, чтобы определить количество дней в месяце. Если введен недопустимый номер месяца, программа выдаст сообщение об ошибке. В приведенном коде предполагается, что високосный год не учитывается, и февраль всегда имеет 28 дней. Если вам нужно учесть високосные годы, вам придется добавить дополнительную логику для этого.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 437
Информатика 10
Информатика 10
Информатика 43
Информатика 22
Информатика 42
Информатика 62
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
