
Напишите программу сортировки 10 чисел сгенерированных от 0 до 100. И отсортировать их от
максимального до минимального. В Паскале программу (Рандом и массив)

Ответы на вопрос

// PascalABC.NET 3.2, сборка 1356 от 04.12.2016
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(10,0,100); a.Println;
Sort(a,(x,y)->x>=y); a.Println
end.
Пример
49 17 50 84 14 9 69 5 40 70
84 70 69 50 49 40 17 14 9 5



Генерация случайных чисел и сортировка в Паскале
Для генерации 10 случайных чисел от 0 до 100 и их сортировки от максимального до минимального в Паскале, можно использовать следующий код:
```pascal program SortAndPrint; var numbers: array[1..10] of Integer; i, j, temp: Integer; begin Randomize; // Инициализация генератора случайных чисел // Заполнение массива случайными числами for i := 1 to 10 do numbers[i] := Random(101); // Генерация случайного числа от 0 до 100
// Сортировка массива от максимального до минимального for i := 1 to 9 do for j := i + 1 to 10 do if numbers[i] < numbers[j] then begin temp := numbers[i]; numbers[i] := numbers[j]; numbers[j] := temp; end;
// Вывод отсортированных чисел for i := 1 to 10 do WriteLn(numbers[i]); end. ```
Этот код создает программу, которая генерирует 10 случайных чисел от 0 до 100, сохраняет их в массиве, сортирует массив от максимального до минимального и выводит отсортированные числа.
Объяснение кода
- `Randomize` инициализирует генератор случайных чисел, чтобы обеспечить разнообразие случайных чисел при каждом запуске программы. - Цикл `for i := 1 to 10 do` заполняет массив `numbers` 10 случайными числами от 0 до 100. - Далее используется алгоритм сортировки пузырьком для сортировки массива от максимального до минимального. - Наконец, отсортированные числа выводятся на экран.
Этот код демонстрирует простой способ генерации случайных чисел, их сортировки и вывода отсортированных результатов в языке Паскаль.


Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili