
Информатика, 9 класс (много баллов!) ЯП Паскаль, помогите пожалуйста •Найти сумму положительных
элементов массива размером 5. •Найти произведение элементов массива кратных 6. Размер массива равен 10. В массиве точно должны быть такие элементы. •Дан массив размером 5. Его положительные элементы утроить, а отрицательные и равные 0 увеличить на 5. Вывести новые элементы массива.

Ответы на вопрос

Ответ:
1)var
a:array[1..5]of integer;
i,n,s:integer;
begin
writeln('Введите кол-во элементов');
readln(n);
writeln('Введите число');
s:=0;
for i:=1 to n do begin
read(a[i]);
if a[i]>0 then s:=s+a[i]
end;
writeln('Сумма положительных элементов массива равна ', s)
end.
2)var
a:array[1..10]of integer;
i,n,P:integer;
begin
writeln('Введите число элементов');
readln(n);
writeln('Введите число');
P:=1;
for i:=1 to n do begin
read(a[i]);
if a[i] mod 6 = 0
then P:=P*a[i]
end;
writeln('Произведение элементов массива кратных 6 равна ',P)
end.
3)var
a:array[1..5]of integer;
n,i:integer;
begin
writeln('Введите кол-во элементов');
readln(n);
writeln('Введите число');
for i:=1 to n do begin
read(a[i]);
if a[i]>0 then begin
a[i]:=a[i]*3;
writeln('Новый элемент равен: ',a[i])
end;
if a[i]<=0 then begin
a[i]:=a[i]+5;
writeln('Новый элемент равен: ',a[i])
end;
end;
end.
Буду рад если отметишь мой ответ как лучший



Конечно, я могу помочь вам написать программу на языке Pascal для решения данных задач. Вот код для каждой из них:
- Найти сумму положительных элементов массива размером 5:
pascalprogram SumPositiveElements; var arr: array[1..5] of integer; i, sum: integer; begin sum := 0; writeln('Введите 5 элементов массива:'); for i := 1 to 5 do begin readln(arr[i]); if arr[i] > 0 then sum := sum + arr[i]; end; writeln('Сумма положительных элементов массива: ', sum); end.
- Найти произведение элементов массива, кратных 6 (размер массива 10):
pascalprogram ProductOfMultiplesOf6; var arr: array[1..10] of integer; i, product: integer; begin product := 1; writeln('Введите 10 элементов массива:'); for i := 1 to 10 do begin readln(arr[i]); if (arr[i] mod 6 = 0) then product := product * arr[i]; end; writeln('Произведение элементов, кратных 6: ', product); end.
- Умножить положительные элементы массива на 3, а отрицательные и равные 0 увеличить на 5:
pascalprogram ModifyArray; var arr: array[1..5] of integer; i: integer; begin writeln('Введите 5 элементов массива:'); for i := 1 to 5 do begin readln(arr[i]); if arr[i] > 0 then arr[i] := arr[i] * 3 else if arr[i] <= 0 then arr[i] := arr[i] + 5; end; writeln('Измененные элементы массива:'); for i := 1 to 5 do writeln(arr[i]); end.
Эти программы решат ваши задачи. Надеюсь, это поможет!


Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili