Написать программу в C++, с использованием векторов Дан массив из случайных вещественных
элементов. Найти сумму всех положительных элементов и увеличить каждый элемент исходного массива на это число. Произвести сортировку по убывания этого массива и удалить последний элемент.Ответы на вопрос
#include <iostream>
#include <cstdlib>
#include <ctime>
#include <vector>
#include <algorithm>
using namespace std;
bool myfunction (int i,int j) { return (i>j); }
int oneortwo() {
if(rand()%2==1) {
return 1;
} else {
return -1;
}
}
int main() {
vector<long long int> arr;
srand(time(0));
setlocale(LC_ALL, "Russian");
for(int i = 0; i<5; ++i) {
arr.push_back(rand()*oneortwo());
cout << arr[arr.size()-1] << " ";
}
long long sum = 0;
for(int i = 0; i<arr.size(); ++i) {
if(arr[i]>=0) {
sum+=arr[i];
}
}
for(int i = 0; i<arr.size(); ++i) {
arr[i]*=sum;
}
sort(arr.begin(), arr.end(), myfunction);
arr.erase(arr.begin()+arr.size()-1);
cout << endl << endl;
for(int i = 0; i<arr.size(); ++i) {
cout << arr[i] << " ";
}
}
Вот пример программы на C++, которая выполняет указанные операции с массивом с использованием векторов:
cpp#include <iostream>
#include <vector>
#include <algorithm>
int main() {
// Создаем вектор и заполняем его случайными вещественными элементами.
std::vector<double> arr = {1.5, -2.3, 3.7, -4.1, 5.2, 6.4, -7.6};
// Находим сумму всех положительных элементов.
double sum = 0.0;
for (const double& num : arr) {
if (num > 0) {
sum += num;
}
}
// Увеличиваем каждый элемент исходного массива на сумму положительных элементов.
for (double& num : arr) {
num += sum;
}
// Сортируем вектор по убыванию.
std::sort(arr.rbegin(), arr.rend());
// Удаляем последний элемент.
if (!arr.empty()) {
arr.pop_back();
}
// Выводим измененный массив.
std::cout << "Измененный массив: ";
for (const double& num : arr) {
std::cout << num << " ";
}
std::cout << std::endl;
return 0;
}
Замените значения в векторе arr на свои случайные вещественные числа. Этот код найдет сумму положительных элементов, увеличит каждый элемент на эту сумму, выполнит сортировку по убыванию и удалит последний элемент.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
