Вопрос задан 01.10.2023 в 22:30. Предмет Информатика. Спрашивает Закиев Данил.

Напишите программу, которая вводит с клавиатуры три числа, и находит их сумму и произведение. (на

языке Паскаль)​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Кобякова Александра.

Ответ:

var n, sum, mult: integer;

begin

write('Enter number: ');

readln(n);

sum := 0;

mult := 1;

while n > 0 do begin

sum := sum + n mod 10;

mult := mult * (n mod 10);

n := n div 10

end;

writeln('Sum of digits = ', sum);

writeln('Multiplication of digits = ', mult);

readln

end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот программа на языке Pascal, которая вводит три числа с клавиатуры, находит их сумму и произведение:

pascal
program SumAndProduct; var num1, num2, num3, sum, product: real; begin writeln('Введите первое число: '); readln(num1); writeln('Введите второе число: '); readln(num2); writeln('Введите третье число: '); readln(num3); // Найдем сумму трех чисел sum := num1 + num2 + num3; // Найдем произведение трех чисел product := num1 * num2 * num3; writeln('Сумма введенных чисел: ', sum); writeln('Произведение введенных чисел: ', product); readln; end.

Сначала программа запрашивает ввод трех чисел с клавиатуры, затем вычисляет и выводит их сумму и произведение.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос