Вопрос задан 30.09.2023 в 16:28. Предмет Информатика. Спрашивает Пафиков Виктор.

Напишите программу на C ++ для вычисления сумму и среднего четырех чисел.10. Напишите программу на

C ++, чтобы проверить, является ли число положительным или отрицательным Напишите программу на C ++, чтобы определить, является ли целое число четным или нечетным​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Плотникова Даша.

Ответ:

int a = 3;

if(a % 2 == 0)

  //четное

else

  //не четное

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот примеры программ на C++ для выполнения указанных задач:

  1. Программа для вычисления суммы и среднего четырех чисел:
cpp
#include <iostream> using namespace std; int main() { double num1, num2, num3, num4; double sum, average; cout << "Введите четыре числа: "; cin >> num1 >> num2 >> num3 >> num4; sum = num1 + num2 + num3 + num4; average = sum / 4; cout << "Сумма: " << sum << endl; cout << "Среднее: " << average << endl; return 0; }
  1. Программа для проверки, является ли число положительным или отрицательным:
cpp
#include <iostream> using namespace std; int main() { int number; cout << "Введите число: "; cin >> number; if (number > 0) { cout << "Число положительное." << endl; } else if (number < 0) { cout << "Число отрицательное." << endl; } else { cout << "Число равно нулю." << endl; } return 0; }
  1. Программа для определения, является ли целое число четным или нечетным:
cpp
#include <iostream> using namespace std; int main() { int number; cout << "Введите целое число: "; cin >> number; if (number % 2 == 0) { cout << "Число четное." << endl; } else { cout << "Число нечетное." << endl; } return 0; }

Вы можете скомпилировать и запустить каждую из этих программ, чтобы проверить их работоспособность.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос