
Дан массив А из n действительных чисел: a1, …, an. Вычислить: а) |a1|+…+|an| б) |a1|×|a2|×…|an|
Определить количество элементов массива: а) кратных 3 и некратных 5; б) являющихся квадратами четных чисел. (В ПАскаль)

Ответы на вопрос

var a:array[1..10000] of integer;
n,i,mult,summa:integer;
begin
read(n);
summa = 0;
mult = 0;
k = 0;
for i:=1 to n do
begin
read(a[i]);
summa = summa + a[i];
mult = mult * a[i];
if (a[i] mod 3 = 0) and (a[i] mod 5 <>0) then
inc(k)
end;
writeln('a' - summa,'b' - mult,'a' - k
end.



Вот как вы можете написать программу для вычисления указанных задач на языке программирования Pascal:
а) Вычисление суммы модулей элементов массива:
pascalprogram CalculateSumOfAbsoluteValues; var A: array of Real; n, i: Integer; sum: Real; begin Write('Введите количество элементов массива: '); ReadLn(n); SetLength(A, n); WriteLn('Введите элементы массива:'); for i := 0 to n - 1 do begin ReadLn(A[i]); // Добавляем модуль элемента к сумме sum := sum + Abs(A[i]); end; WriteLn('Сумма модулей элементов массива: ', sum); end.
б) Вычисление произведения модулей элементов массива:
pascalprogram CalculateProductOfAbsoluteValues; var A: array of Real; n, i: Integer; product: Real; begin Write('Введите количество элементов массива: '); ReadLn(n); SetLength(A, n); WriteLn('Введите элементы массива:'); for i := 0 to n - 1 do begin ReadLn(A[i]); // Умножаем модуль элемента на текущее значение произведения if i = 0 then product := Abs(A[i]) else product := product * Abs(A[i]); end; WriteLn('Произведение модулей элементов массива: ', product); end.
в) Определение количества элементов массива, кратных 3 и некратных 5:
pascalprogram CountMultiplesOf3AndNot5; var A: array of Integer; n, i, count: Integer; begin Write('Введите количество элементов массива: '); ReadLn(n); SetLength(A, n); count := 0; WriteLn('Введите элементы массива:'); for i := 0 to n - 1 do begin ReadLn(A[i]); // Проверяем условия и увеличиваем счетчик при необходимости if (A[i] mod 3 = 0) and (A[i] mod 5 <> 0) then count := count + 1; end; WriteLn('Количество элементов, кратных 3 и некратных 5: ', count); end.
г) Определение количества элементов массива, являющихся квадратами четных чисел:
pascalprogram CountSquaresOfEvenNumbers; var A: array of Integer; n, i, count: Integer; begin Write('Введите количество элементов массива: '); ReadLn(n); SetLength(A, n); count := 0; WriteLn('Введите элементы массива:'); for i := 0 to n - 1 do begin ReadLn(A[i]); // Проверяем, является ли элемент квадратом четного числа if (A[i] mod 2 = 0) and (Sqrt(A[i]) = Trunc(Sqrt(A[i]))) then count := count + 1; end; WriteLn('Количество элементов, являющихся квадратами четных чисел: ', count); end.
Эти программы позволят вам выполнить указанные задачи на языке Pascal.


Похожие вопросы
Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili