Вопрос задан 29.09.2023 в 07:31. Предмет Информатика. Спрашивает Михеева Алина.

№9. Напишите программу, которая вводит два целых числа и находит их произведение, не используя

операцию умножения. Учтите, что числа могут быть отрицательными. Входные данные Входная строка содержит два целых числа. Выходные данные Программа должна вывести произведение введённых чисел
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Беспалов Тимофей.

Ответ:

1 Вариант:

numbers=list(map(int,input().split()))

if numbers[0] == 0 or numbers[1] == 0:

   print(0)

else:

   print(numbers[0]/(1/numbers[1]))

2 Вариант:

numbers=list(map(int,input().split()))

summ=0

if numbers[1]<0 and numbers[0]<0:

   for i in range(-numbers[0]):

       summ+=-numbers[1]

elif numbers[1]<0:

   for i in range(numbers[0]):

       summ+=numbers[1]

else:

   for i in range(numbers[1]):

       summ+=numbers[0]

print(summ)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вы можете написать программу на Python, которая будет находить произведение двух целых чисел, не используя операцию умножения, с учетом отрицательных чисел. Одним из способов сделать это является использование цикла для сложения числа n раз, где n - второе число. Если второе число отрицательное, то вы будете вычитать первое число n раз. Вот пример такой программы:

python
# Ввод двух целых чисел num1 = int(input("Введите первое целое число: ")) num2 = int(input("Введите второе целое число: ")) # Инициализация переменной для хранения произведения product = 0 # Определение знака второго числа sign = 1 if num2 < 0: sign = -1 num2 = abs(num2) # Вычисление произведения for i in range(num2): product += num1 # Применение знака ко второму числу product *= sign # Вывод результата print("Произведение чисел:", product)

Этот код сначала запрашивает у пользователя два целых числа, затем использует цикл для сложения первого числа с собой n раз (где n - второе число), учитывая знак второго числа. Результат выводится на экран.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос