Вопрос задан 17.06.2023 в 14:36. Предмет Информатика. Спрашивает Тарасов Кирилл.

Помогите написать программу на питоне пожалуйста. Напишите программу, которая вводит два целых

числа и находит их произведение, не используя операцию умножения. Учтите, что числа могут быть отрицательными. Входные данные Входная строка содержит два целых числа. Выходные данные Программа должна вывести произведение введённых чисел. Примеры входные данные 6 12 выходные данные 72 входные данные -7 15 выходные данные -105
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Брунь Виктория.

Ответ:

x = int(input("Введите первое число"))

y = int(input("Введите второе число"))

result = 0

z = 0

 

while z != (abs(y)):

   result = result+(abs(x))

   z=z+1

 

if (x<0 and y>0) or (x>0 or x<y):

  result = -result

 

print(result)

Объяснение:

0 0
Отвечает Боголюбов Тимоха.

Ответ:

Объяснение:

x = int(input())

y = int(input())

res = 0

for k in range(abs(x)):

   res += y

worklist = [x,y]

worklist.sort()

if 0 in range(worklist[0],worklist[1]):

   res = -res

print(res)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот программа на Python, которая находит произведение двух целых чисел, не используя операцию умножения:

```python def multiply_without_operator(a, b): # Инициализация переменной для хранения результата result = 0

# Определяем знак результата sign = 1 if (a < 0) ^ (b < 0): sign = -1

# Приводим числа к положительным значениям для удобства работы a = abs(a) b = abs(b)

# Складываем 'a' 'b' разы for i in range(b): result += a

# Учитываем знак результата result *= sign

return result

# Получаем ввод от пользователя input_numbers = input("Введите два целых числа через пробел: ").split() num1 = int(input_numbers[0]) num2 = int(input_numbers[1])

# Находим произведение и выводим результат result = multiply_without_operator(num1, num2) print("Произведение введенных чисел:", result) ```

Вы можете запустить эту программу, введя два целых числа через пробел, как показано в примерах входных данных, и она выведет произведение этих чисел, не используя операцию умножения.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос