
Кто хорошо знает язык программирования Pascal или C++ пожалуйста, помогите сделать код из этой так
сказать задачи. Сегодня у Илоны был последний экзамен. Теперь она знает все свои оценки за сессию. Оценки в Университете имени Юпитера выставляются в 100-балльной шкале.Если у студента все оценки отличные (не менее 90), то ему назначается повышенная стипендия.Если все оценки студента не менее 51, но он не имеет права на повышенную стипендию, он получает обычную стипендию.Если студент имеет хоть одну неудовлетворительную оценку (менее 51), ему стипендия не назначается.Входные данные В первой строке содержится целое число n экзаменов на сессии. В следующей строке записаны n целых чисел a[i] оценки Илоны Максимовной.Выходные данные В единственной строке выведите Повышенная, Обычная или Забудь про стипендию, в зависимости от того, какой стипендии заслужила Илона.Входные данные (stdin) Выходные данные (stdout)751 74 61 81 77 71 90 Обычная стипендия494 90 100 100 Повышенная стипендия44 7 47 74 Забудь про стипендиюБуду очень благодарен если поможете, спасибо!

Ответы на вопрос

Ответ:
#include <iostream>
using namespace std;
int main()
{
int n,a;
bool f1, f2, f3;
f1 = false; f2 = false; f3 = false;
cin >> n;
for (int i = 1; i < n; i++)
{
cin >> a;
if (a < 51) {f3 = true; break; }
if (a >= 90) {f1 = true;}
if (a >= 51 && a < 90) { f2 = true; }
}
if (f3) { cout << "Забудь про стипендию" << "\n"; }
else
if (f1 && !f2 && !f3) {
cout << "Повышенная" << "\n";
} else {if (f2 && !f1 && !f3){ cout << "Обычная" << "\n"; }}
}
Объяснение:



Конечно, вот код на языке программирования Pascal, который решает вашу задачу:
pascalprogram Stipendia; var n, i, grade, minGrade: integer; hasUnsatisfactory: boolean; begin hasUnsatisfactory := False; minGrade := 51; readln(n); // Считываем количество экзаменов for i := 1 to n do begin read(grade); // Считываем оценку за текущий экзамен if grade < minGrade then hasUnsatisfactory := True; end; if not hasUnsatisfactory then begin // Если нет неудовлетворительных оценок, проверяем на повышенную стипендию for i := 1 to n do begin if grade < 90 then begin writeln('Обычная стипендия'); exit; // Завершаем программу end; end; writeln('Повышенная стипендия'); end else begin // Если есть хотя бы одна неудовлетворительная оценка writeln('Забудь про стипендию'); end; end.
Вы можете скопировать этот код и выполнить его в среде программирования Pascal. Он считывает количество экзаменов, затем считывает оценки за каждый экзамен и выводит соответствующий результат в зависимости от условий задачи.


Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili