Составить программу определения количества положительных и отрицательных элементов массива целых
чисел.Ответы на вопрос
         Program n1;
const n=10;
var a: array[1..n] of integer;
i,ko,kp: integer;
begin
randomize;
ko:=0;
kp:=0;
writeln('исходный массив:');
for i:=1 to n do
begin
a[i]:=random(21)-10;
write(a[i],' ');
if a[i]>0 then kp:=kp+1;
if a[i]<0 then ko:=ko+1;	
end;
writeln;
writeln('кол-во пол: ',kp);
writeln('кол-во отр: ',ko);	
end. 
         Program n1;
const n=10;
var a: array[1..n] of integer;
i,ko,kp: integer;
begin
randomize;
ko:=0;
kp:=0;
writeln('исходный массив:');
for i:=1 to n do
begin
a[i]:=random(21)-10;
write(a[i],' ');
if a[i]>0 then 
if a[i]<0 then ko:=ko+1;
w
w
e 
            Программа для определения количества положительных и отрицательных элементов массива целых чисел
Вот пример программы на языке программирования C, которая позволяет определить количество положительных и отрицательных элементов в массиве целых чисел:
```c
#include 
#define N 10
int main() { int A[N]; int positiveCount = 0; int negativeCount = 0;
printf("Введите %d целых чисел:\n", N); for (int i = 0; i < N; i++) { scanf("%d", &A[i]); if (A[i] > 0) { positiveCount++; } else if (A[i] < 0) { negativeCount++; } }
printf("Количество положительных элементов: %d\n", positiveCount); printf("Количество отрицательных элементов: %d\n", negativeCount);
return 0; } ```
Программа запрашивает у пользователя ввод 10 целых чисел и подсчитывает количество положительных и отрицательных элементов в массиве. Результаты подсчета выводятся на экран.
Примечание: В данном примере используется массив `A` размером 10 элементов (`#define N 10`). Вы можете изменить размер массива, если вам нужно обработать больше или меньше чисел.
Пример использования программы
``` Введите 10 целых чисел: 1 -2 3 -4 5 6 -7 8 -9 10 Количество положительных элементов: 6 Количество отрицательных элементов: 4 ```
В этом примере пользователь вводит 10 целых чисел, и программа выводит количество положительных и отрицательных элементов в массиве.
Обратите внимание: Программа предполагает, что пользователь будет вводить только целые числа. Если пользователь вводит что-то отличное от целых чисел, программа может работать некорректно. В реальном приложении следует предусмотреть проверку ввода на корректность.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
- 
			
Математика
 - 
			
Литература
 - 
			
Алгебра
 - 
			
Русский язык
 - 
			
Геометрия
 - 
			
Английский язык
 - 
			
Химия
 - 
			
Физика
 - 
			
Биология
 - 
			
Другие предметы
 - 
			
История
 - 
			
Обществознание
 - 
			
Окружающий мир
 - 
			
География
 - 
			
Українська мова
 - 
			
Информатика
 - 
			
Українська література
 - 
			
Қазақ тiлi
 - 
			
Экономика
 - 
			
Музыка
 - 
			
Право
 - 
			
Беларуская мова
 - 
			
Французский язык
 - 
			
Немецкий язык
 - 
			
МХК
 - 
			
ОБЖ
 - 
			
Психология
 - 
			
Физкультура и спорт
 - 
			
Астрономия
 - 
			
Кыргыз тили
 - 
			
Оʻzbek tili
 
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			