Вопрос задан 27.09.2023 в 12:31. Предмет Информатика. Спрашивает Кузнецова Вероника.

Если в питоне неверно решил пример, то программа сообщает правильный ответ. Как написать?

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Иващенко Валя.

Ответ:

from random import randint

while 1:

   a = randint(1, 100)

   b = randint(1, 100)

   answer = 0

   while not answer:

       try:

           answer = int(input(f'{a} + {b} = '))

       except:

           print('Введите число!')

   if answer == a+b:

       print('Верно!')

   else:

       print(f'Неверный ответ!\nПравильный ответ: {a+b}')

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Чтобы написать программу на Python, которая сообщает правильный ответ, если пользователь неверно решает пример, вы можете использовать конструкцию условия (if-else). Вот пример программы, которая генерирует случайный математический пример и проверяет ответ пользователя:

python
import random # Генерируем два случайных числа от 1 до 10 num1 = random.randint(1, 10) num2 = random.randint(1, 10) # Вычисляем правильный ответ correct_answer = num1 + num2 # Задаем пользователю вопрос user_answer = int(input(f"Сколько будет {num1} + {num2}? ")) # Проверяем ответ пользователя if user_answer == correct_answer: print("Правильно! Ответ:", correct_answer) else: print("Неправильно. Правильный ответ:", correct_answer)

В этом примере программа генерирует два случайных числа и складывает их, чтобы получить правильный ответ. Затем она спрашивает пользователя, сколько будет сумма этих чисел, и сравнивает ответ пользователя с правильным. Если ответ пользователя правильный, программа сообщает об этом, иначе она сообщает правильный ответ.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос